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AUTOMATED BLENDER WORK FLOW 

 

This is the process for using agrē with automated blending systems. The systems use similar 
controls, but not all features are available in each system. 
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Before You Blend (one time setup tasks) 

Security Setup 

The first thing you’ll need to do is give yourself security access to Automated Blend Orders. 

Navigate to File > Security > Manage Roles. Select the appropriate role (e.g. Administrator) and 
Edit the role. Navigate to the Blend tab, click Automated Blend Orders and click Allow. 

 

File > Security > Manage Roles – Blending tab 

Still on the Blending tab, scroll down to the bottom of the list to Manage Automated Blenders 
and click Allow. Click Save. 

 

File > Security > Manage Roles – Blending tab 
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Automated Blender Setup 

Before you can start sending blends to an automated blender, you need to let agrē know how it’s 
setup. 

Navigate to Manage Automated Blenders. Click on the down arrow next to Blend System and 
choose [location]: [automated blender type]. Click Retrieve. 

 
Blending > Manage > Automated Blenders 

Note Not every automated feature is compatible with every automated 
blender.  
If a feature is not displayed, or a value cannot be entered, it is not 
supported by that Blend System. 

AGI Yargus/Kahler/Stockdales 

 



Automated Blender Work Flow  Page 4 of 22 

Specify the Import and Export file locations (these will be unique to your network, and will likely 
not match the path shown). 

Important The Import/Export folders need to be setup on your network and shared out 
to all local machines and users. All users/workstations running agrē that will 
send to the automated blender need to have a mapped network drive 
pointing to these shared folders and the drive letter needs to be the same 
for each user/workstation. Please consult the documentation supplied with 
your automated blender for details. 
 
Please contact your company’s local IT Support for assistance with setting up 
the shares on your local network. 

Specify the Scale Conversion (in this example agrē uses MT and the automated blender uses KG 
so the conversion is 1000).  

(optional) Check the Send Extended Blend Information box to send the blend name, blend 
description, application rate and acres in addition to the product information to the automated 
blender. 

(optional) Check the Prompt whether Delivery Charge should be added box and fill in the details.  

Click Save. 

 

agrē Product Unit ID Codes 

The automated blend system requires agrē unit codes (these are entered outside of agrē into the 
automated blender’s software as part of its setup process); you can find these codes in the 
Product Unit Types data export. 

 

File > Exports > Data 
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ICS/LV/Rancan/Ranco/Shift Innovation 

 
Hosted retailers must use the format: \\client\X$\folder\subfolder\  (for both Import and Export folders) 

Standalone retailers can use the format: X:\folder\subfolder\  (for both Import and Export folders) 

Note Not every automated feature is compatible with every automated 
blender.  
If a feature is not displayed, or a value cannot be entered, it is not 
supported by that Blend System. 

Specify the Import and Export file locations (these will be unique to your network, and will likely 
not match the example path shown),  

Important The Import/Export folders need to be setup on your network and shared out 
to all local machines and users. All users/workstations running agrē that will 
send to the automated blender need to have a mapped network drive 
pointing to these shared folders and the drive letter needs to be the same 
for each user/workstation. Please consult the documentation supplied with 
your automated blender for details. 
 
Please contact your company’s local IT Support for assistance with setting up 
the shares on your local network. 

Specify the Mix Times, and the Scale Conversion (in this example, agrē uses MT and the 
automated blender uses KG so the conversion is 1000).  
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Blends will be sent to Batch System 1 by default, but this can be changed. When Prompt is the 
default, you’ll be asked to select the Batch System on the fly when the targets are sent to the 
automated blender.  

(optional) Include Additional Products  Check if Additional Products in Blends will be sent to the 
automated blender. Additional product setup will be required. 

Depending on which Blend Notes option is selected, agrē will send to the automated blender 
either: 

• the WO Release/Reference Number or  

• the Blend Description 

(optional) Check the Prompt whether Delivery Charge should be added box and fill in the details.  

(optional) In the Liquid/Oil Additive section, check Prompt whether Oil should be added and fill in 
the details.  

The Spray Quantity is the rate at which the oil is applied in L/Min.  

Notes Changing the Oil Rate (and/or Limit) will be the one task in this section 
that you will do more than once. This is where you’ll go to change the 
quantity of oil sprayed depending on daily weather conditions, 
additives, etc. 

The Oil Rate is how much to apply, in either L/MT or mL/acre. 

• If mL/acre is selected, each blend sent must include acres (agrē will automatically convert 
mL/acre to L/MT using the blend acres [Oil Rate * Blend Acres / 1000]). 

If entered, Limit will be the cap for the maximum L/MT of oil applied. 

Click Save. 
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Customer Setup 

Each grower will need their automated blender customer code/member account number added 
to their customer account. 

Navigate to Accounts Receivable > Manage > Customers. Search for the customer and Edit their 
account. In the IBC Member No. field, add their Integrated Blender Customer Number/Code. 
Save your changes. 

 
Accounts Receivable > Manage > Customers 

Repeat for all customers in locations with the automated blender. 

Blend Product Setup 

Each product will need a unique Controller Mapping Code. 

Navigate to Inventory > Manage > Products. Search for the blend product and Edit .  
Fill in the Controller Mapping Code (must be a whole number). Save your changes. 

 
Inventory > Manage > Products 

Repeat for all products that will be blended in the automated blender. 
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LV/Ranco/Shift Innovation Only: Additional Product in Blend Setup 

Navigate to Inventory > Manage > Products. Search for the blend product and Edit .  
Check Blendable. 

 
Inventory > Manage > Products 

Ensure the Main Unit of the Blend Type … 

 

Blending > Manage > Blend Types 

… is listed as a Unit Type with a Conversion Factor. 

 

Inventory > Manage > Products 
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Fill in the Controller Mapping Code (must be a unique whole number).  

 
Inventory > Manage > Products 

Save your changes. 

Repeat for all additional products that will be added to blends sent to the automated blender. 
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Easy Automation 

 

Specify the Scale Conversion (in this example agrē uses MT and the automated blender uses KG 
so the conversion is 1000).  

Update Total Blend Qty  When Receiving Actuals, retrieve the actual Total Quantity instead of 
the actual quantities of each commodity. 

(optional) Include Additional Products  Check if Additional Products in Blends will be sent to the 
automated blender. Additional product setup will be required. 

Note Additional Products are not included in the Total Blend Quantity. 

(optional) Check the Prompt whether Delivery Charge should be added box and fill in the details.  

Easy Automation blenders are connected through a web service and require a static IP address. If 
this is your first Easy Automation blender you will need to purchase a static IP from your internet 
service provider and pass on this information to Tronia so we can setup a port forwarded to your 
blender’s server. Please note that there may be setup of additional network infrastructure at the 
blender location. 
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Customer Setup 

Each grower will need their automated blender customer code/member account number added 
to their customer account. 

Navigate to Accounts Receivable > Manage > Customers. Search for the customer and Edit their 
account. In the IBC Member No. field, add their Integrated Blender Customer Number/Code. 
Save your changes. 

 
Accounts Receivable > Manage > Customers 

Repeat for all customers in locations with the automated blender. 

 

Blend Product Setup 

Each product will need a unique numeric-only Controller Mapping Code. 

Navigate to Inventory > Manage > Products. Search for the blend product and Edit .  
Fill in the Controller Mapping Code (must be a whole number). Save your changes. 

 
Inventory > Manage > Products 

Repeat for all products that will be blended in the automated blender. 
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Additional Product in Blend Setup 

Navigate to Inventory > Manage > Products. Search for the blend product and Edit .  
Check Blendable. 

 
Inventory > Manage > Products 

Ensure the Main Unit of the Blend Type … 

 

Blending > Manage > Blend Types 

… is listed as a Unit Type with a Conversion Factor. 

 

Inventory > Manage > Products 
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Fill in the Controller Mapping Code (must be a unique whole number).  

 
Inventory > Manage > Products 

Save your changes. 

Repeat for all additional products that will be added to blends sent to the automated blender. 

 

Optional - Set Loadout Ticket Print Defaults 
(for all automated blender systems) 

Let agrē know if you want to print each Loadout Ticket (or any other report) after you save it. 

Navigate to Company Level Settings. Click on the Reports tab, then the Report Options subtab. 
In the Offer to Print on Save box, check the appropriate boxes. Batch Sheets are not normally 
needed for automated blenders. 

 

File > Config Options > Company / Reports / Printing Options 

When you save a Loadout Ticket for the first time you’ll be prompted to print only what you 
need. 
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Sending the Target Blend  

Targets are sent to automated blenders from a Loadout Ticket.  
Add a blend to the LOT and click Send Target. 

 

Caution If you are going to link this blend to work order(s) wait until AFTER you 
receive the actuals. 

 

 

If you have more than one blender at a Location, you will be prompted to Select Blender for the 
targets. 
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LV/Rancan/RANCO/Shift Innovation Blenders Only 

Depending on the default Batch System selected in the Automated Blender Setup, you may be 
prompted to Select your Batch System.  

 

 

 

 

Easy Auto/LV/Ranco/Shift Innovation Blenders Only 

When Making a Blend, any Additional Product that will be blended must be flagged as Include in 
Blend. 

 

Accounts Receivable > Loadout Ticket > Add Blend 
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All Auto Blenders 

If you receive the “No Customer Mapping” warning, it’s an indication that the IBC Member No 
(integrated blend control number) is missing from the customer’s account. You will need to edit 
the customer’s account and add the IBC customer code to the IBC Member No. field before you 
can send their blends to the automated blender. 

 

To add an IBC Member No. to the customer account on the fly from the LOT, navigate to the 
Customer and Shipping tab and click Manage This Customer. 

 

Accounts Receivable > Manage > Customers 

 

 

If you’ve specified to be prompted for an oil product, you’ll be asked if you want to add liquid to 
the blend. Click Yes to add it, or No to leave it out. 

.  
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If you’ve chosen an oil application rate based on mL/acre, and the blend sent has no acres (e.g. it 
was calculated based on Quantities instead of NPK), you will be prompted to edit the blend. 

 

 

The Automated Blender status changes to Sent. If you chose to add oil, that product is added to 
the LOT in the quantity calculated by the rate specified. 
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Receiving Actuals  

After the blend is mixed, click Receive Actuals. 

 

Caution If you are going to link this blend to work order(s) wait until AFTER you 
receive the actuals.  
 
If you forgot and linked before, and any product row was split, when you 
Receive Actuals you will see this message: 

 
You will need to edit the blend, Reset Links, and save the blend. Then you 
can receive the actuals, and re-link the blend. 

LV Blenders Only 

LV blenders require approximately 2 minutes after the end of Batch/Accept Weight to generate 
the Actuals file agrē will import. You’ll see an error if you don’t wait quite long enough.  
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All Auto Blenders 

If you’ve specified to be prompted for delivery, you’ll be asked if you want to add delivery to the 
loadout ticket. Click Yes to add it, or No to leave it off. 

 

The Automated Blender status changes to Received, and the blend product quantities are the 
actual quantities used to make the blend. Save the Loadout Ticket. 

 

Now that you’ve got the actuals back, you can link to a work order (if needed). 
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Printing the Loadout Tickets 

If you’ve you specified that you want to print LOTs on Save, agrē will prompt you to print. Click 
Preview (pressing ALT+P is the keyboard shortcut). 

 

  



Automated Blender Work Flow  Page 21 of 22 

Managing Automated Blender Orders 

The purpose of managing Automated Blend Orders is to allow you to change the Status of a 
Blend Order manually. This would only be needed if there was a deviation from the usual 
process. For example, an order was sent to the automated blend control system then it was 
realized that it could not (or should not) be loaded. 

The only column that can be edited on this form is the Status, but you can change the status of 
any order to any status.  

Navigate to Blending > Automated Blend Orders.  
Select the relevant location and dates, then click Find Orders. 

 

Click the dropdown arrow next to the order you want to change and select the new status. Save 
your changes. 

 

Tip The Automated Blend Orders are sorted ascending by Order number by 
default, but you can click on any column header to change it. 
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Reporting 

The Automated Blend Orders report provides you with the details about each order sent to the 
automated blending system. 

Navigate to Blending > Reports > Automated Blend Orders. 
Specify the criteria and click Preview. 

 

 

Each order that has been sent to the system is listed, along with its details. 

 

 

 


