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CRM – CUSTOMER RELATIONSHIP MANAGEMENT 

Customer Relationship Management is identifying, developing and retaining profitable 
customers to build lasting relationships and long-term financial success.  

The agrē CRM module allows you to setup custom attributes (additional fields on the customer 
account that you define), track customer activities (reminders are optional), and store customer 
documents. 
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What is Customer Relationship Management? 

CRM is based on the idea that the better you know your customers, the better you can serve 
them and the more successful your business will be. 

The agrē CRM module is comprised of the following components: 

1) Custom Attributes 

2) CRM Activities 

3) Document Manager 
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Custom Attributes 

If you’ve ever said “I wish there was a field on the customer account form for …” you’re going 
to love custom attributes. Custom Attributes are like customer characteristics in that you 
manage them yourself, but they are much more flexible.  

 

 

Want to know which of your customers use FCC or other third party credit or which chemicals 
they prefer to use? Create an attribute for it! Want to track their wife and kids’ names? Create 
an attribute for that too! Whatever kinds of information you want to keep track of, CRM 
Custom Attributes will help make it easy. 

 

Before you create the individual attribute fields to store information, you’ll create groups to 
keep like items together. Attribute groups can be common to all customers, or restricted to 
those of one location. 

 

Although Custom Attributes are controlled and customized by you, we give you three attribute 
groups (types of information) to get you started. Within these groups are a few typical custom 
attributes that you may want to use. These default attributes are just suggestions – you can 
easily choose to remove or edit them and you can add more groups and attributes as needed. 
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Setting up Custom Attribute Groups 

Think of groups as being like a folder or container for attributes. You can’t create a custom 
attribute until you have a group to put it in. Attribute Groups don’t do anything on their own; 
they just store similar attributes together for easier data entry and viewing.  

Navigate to Accounts Receivable > CRM > Manage > Custom Attribute Groups. 

 

Adding an Attribute Group 

In the list are the three default groups: General, Credit, and Farm. These default groups cannot 
be edited, deactivated, or removed but you don’t have to use them if you don’t need them. 
Once you remove all attributes from a group, or deactivate it, it will no longer display on the 
customer account CRM tab. 

To add a new group, start typing its description on the blank line at the bottom of the list and 
press TAB to make the group Active. If the group is for customers of one location only, check 
the box and select it. 

 

If you're adding multiple groups, add them all at once as Save closes the window. 

The order of the groups in the list determines the order and the position of the groups on the 
two-column customer account CRM tab. If there are an odd number of groups, there will be 
one more group on the left hand side of the tab than on the right. Click Move Up or Move 
Down to change the order of the groups. Save your changes. 

Caution  It’s very easy to click Exit instead of Save and accidentally discard your 

changes! 
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Editing an Attribute Group 

To change the spelling of a group, double-click on the group title and type a new one. 

To deactivate an attribute group (the group and its attributes will no longer display on the 
customer account CRM tab) click on the checkmark in the Active column to remove it. You can 
deactivate a group even if it contains active attributes. Save your changes. 

To make a group location-specific, check the Specific Location box and choose the location. Any 
previously entered data for customers not from that location is retained (and will be included in 
the CRM Export) but won't be visible on the CRM tab. 

To make a group universal, uncheck the Specific Location box (which removes the location). 

 

Note Attribute Groups can be deactivated even if they contain active Custom 
Attributes. 

Removing Attribute Groups 

If an attribute group is empty it can be permanently removed. If it contains attributes, you 
would need to remove them before the group could be removed. 

Note You can also deactivate an attribute group instead of removing it 
permanently. Deactivated groups do not appear on the CRM tab. 

Select the group to remove and click Remove Group. Save your changes.  
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Setting up Custom Attributes 

Custom Attributes are the individual data items you want to store. Custom Attributes are 
combined into groups so agrē knows how to display them on the customer account CRM tab. 

Navigate to Accounts Receivable > CRM > Manage > Custom Attributes. 

Custom Attributes are managed within their Group. Select a group and click Retrieve. 

 

A list of the custom attributes contained in this group is shown. 
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Adding Custom Attributes 

An attribute name must be unique within its own group, but attributes with the same name can 
be included in multiple groups. 

Custom Attributes come in 4 varieties: 

1. text box 

2. multi-line text box 

3. check box 

4. dropdown list 
 

For All Attribute Types: 

Click Add. 

 

Adding a Text Box 

 

Type the attribute name. Select Text as the attribute type. Click Update. 
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Adding a Multi-line Text Box 

  

Type the attribute name. Select Text (Multiline) as the attribute type. Click Update. 

 
 

Adding a Check Box 

 

Type the attribute name. Select Checkbox as the attribute type. Click Update. 

 

Adding a Dropdown List 
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Type the attribute name. Select Dropdown as the attribute type.  

 

Click List. 

 

Type the values you want to appear in the dropdown list and press TAB to activate. Click 
Update to save the list values. 

 

Note The list values will be automatically sorted in alphabetical order after 
you Update. 

Click Update to save the dropdown attribute. 
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For All Attribute Types 

Save your changes. 
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Editing Custom Attributes 

Editing attributes is very similar to adding them. It may take less time to edit and customize a 
default attribute than removing it and creating a new one. 

Select the attribute you want to change and click Edit. 

 
 

Changing an Attribute Name 

Change the attribute name by typing new text. This changes only the text label. Existing data 
(information specified in the customer account) will not be affected. Update to save the 
change. 
 

Deactivating Custom Attributes 

Click on the Active checkbox to remove the checkmark. Update to save the change. 

 

Note Deactivated attributes will not display on the customer account CRM 
tab. 
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Editing Dropdown List Choices 

Click List. 

 

To change the spelling of an existing value, double-click and type new text. This changes existing 
data (information specified in the customer account). Update to save the change. 

To add a value to the list, type a new title and press TAB. Update to save your changes. 

 

Note The list values will be sorted in alphabetical order after you Update. 

For All Custom Attributes 

Save your changes. 
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Removing Custom Attributes 

If an attribute is not in use it can be permanently removed from the group. If it has been used, 
you would need to edit every customer account with data in that attribute and clear it before 
the attribute could be removed. 

Select the attribute and click Remove. Save your changes. 

 

 

Tips You could also deactivate an attribute instead of removing it permanently. 
This may be a quicker option if it is currently in use, but you no longer need it. 
 
The CRM Custom Attributes export will identify which customers are 
associated with particular attribute. 
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Using Custom Attribute Information on a Customer Account 

Once your custom attributes are setup, data entry will be done via the customer account CRM 
tab. 

 
or edit via Accounts Receivable > Manage > Customer 
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Custom Attribute Data Exports 

To use the custom attribute information in other applications, export the data from agrē. 

Navigate to File > Exports > Data. 

Help Refer to online Help for more detailed instructions on exporting data. 

 

 

CRM Attribute Export 

Choose CRM Custom Attributes from the dropdown list. 

 

Export to a text file or an Excel file as you would any other data export. 
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Customer List Export 

The Customer List can also include CRM Attribute and CRM Value information. 

 

When choosing to Show CRM Info, if a customer has multiple CRM Attributes the export will 
include multiple rows for that customer. 

 

Note Credit attributes and values are secured and are not included in the 
Customer List export. 
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CRM Activities 

CRM Activities are used to record customer interactions. Called a grower and want to record 
the details of your conversation? Create a CRM Activity for it. A customer called you with 
questions? Write them down in a CRM Activity and set a Reminder to call them back. Been 
trying to collect from a customer for months and need to pass on what you’ve done so far to 
your lawyer? We’ve already created a special category for Credit (Sensitive) activities with 
separate security for that. 

Once you’ve decided on the types of interactions you want to track (phone calls, emails, farm 
visits) you’ll decide how you want to group similar activities together into categories. 

Setting Up CRM Activity Types 

CRM Activity Types are the kinds of interactions you have with your customers: phone calls, 
emails, on-farm visits, etc. We get you started with a few typical types, but you can setup as 
many as you need. 

Navigate to Accounts Receivable > CRM > Manage > Activity Types. 

 

 

Adding a CRM Activity Type 

Type a text label in the blank line at the bottom of the list and press TAB to activate. Save your 
changes. 
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Editing a CRM Activity Type 

To change the spelling of a type, double-click on the title and change the text. Save your 
changes. 

To deactivate a type, click on the checkmark in the Active column to remove it. Save your 
changes. 

 

 

Removing a CRM Activity Type 

If a type is not in use it can be permanently removed. If it has been used, you would need to 
edit every CRM Activity that used that type and select a different one (or delete the activity) 
before the type could be removed. 

Tip You could also deactivate a type instead of removing it permanently. This may 
be a quicker option if it is currently in use, but you no longer need it. 

Select the type and click Remove. Save your changes. 
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Setting Up CRM Activity Categories 

Categories are for grouping similar activities together. We give you a couple of generic 
categories to get you started. These default categories cannot be renamed, removed or 
deactivated. 

Navigate to Accounts Receivable > CRM > Manage > Activity Categories.  

 

Note Because perhaps not all your agrē users should have access to the 
Credit (Sensitive) category, separate permission must be granted to use 
it. 

 

 

Adding a CRM Activity Category 

Type a text label in the blank line at the bottom of the list and press TAB to activate. Save your 
changes. 
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Editing a CRM Activity Category 

To change the spelling of a type, double-click on the type and change the text. Save your 
changes. 

To deactivate a type, click on the checkmark in the Active column to remove it. Save your 
changes. 

 

 

 

Removing a CRM Activity Category 

If a category is not in use it can be permanently removed. If it has been used, you would need 
to edit every CRM Activity that used that category and select a different one (or delete the 
activity) before the category could be removed. 

Note You could also deactivate a category instead of removing it 
permanently. This may be a quicker option if it is currently in use, but 
you no longer need it. 

Select the attribute and click Remove Category. Save your changes. 
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Using CRM Activities 

CRM Activities can be managed from the Customer Account on the CRM Activity tab … 

 

 

… or from the Customer Activity window. 

 
Accounts Receivable > CRM > CRM Activities 

 
 

If using the Customer Activity window is something you'll do often, consider adding the CRM 
Activities shortcut to your toolbar. 

 
Window > Customize Toolbar 
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Adding a CRM Activity 

Select Add (Customer Activity window) or Add Item (Customer Account). 

Choose a customer (if starting from Customer Activity window). 

 
Accounts Receivable > CRM > CRM Activities 

Choose a contact (defaults to main contact), employee (defaults to the logged-in agrē user), 
date (defaults to today), type and category, and type a Description. Notes, Reminders, and 
Farm Fields are optional. 

Add Items and update the status as the activity moves forward. 
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If you want to Remind by Email or Remind by Both, either you and/or the Employee 
(depending on who is selected to be reminded) must have an Email address setup in their User 
Config Options. 

 
File > Config Options > User 

Save the CRM Activity. 
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Attaching Documents to Activities 

While Adding or Editing an activity, click Documents > Add > Browse. Navigate to the folder 
where the document you want to attach is located. 

 

Select the file and click Open. 
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File to Upload defaults to the file you selected. Type a Document Title, and change the Security 
options if applicable. Save to upload the document to agrē. 

 

Note Once a document has been attached to an Activity, the Customer name 
cannot be changed. 

You can attach more than one document to an activity by clicking Add again. When you’ve 
attached all relevant documents, Exit the Documents window.  

 

The number of attached documents is shown on the button. Save the Activity. 

 

Help If you share most documents with your customers, you can set the 
company config option to automatically check Show Document in 
Grower Central by default. You can always change it on the fly when 
uploading the occasional document you don’t want shared. 
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Completing CRM Activities 

When you’re finished with an Activity, flag it as Completed.  

CRM Activities can be Completed: 

• by Editing a CRM Activity 

 

No reminders are generated for Completed activities. 
 

• from the Customer Account’s CRM Activity tab 

 

• from the Customer Activity window 
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Reports for CRM Activity 

CRM Activity 

To print a single activity, select it, View/Preview it, and Print it. 

 

 

CRM Activity Summary Report 

Single Customer 

To view multiple activities for a single customer, run the CRM Activity Summary report from 
their customer account. 

 
Accounts Receivable > Customer Accounts 
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Multiple Customers - more criteria too 

You can get results for multiple customers by running it from the menu.  
You also get more criteria options when running from the menu: 

 
Accounts Receivable > Reports 
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Exporting Calendar Entries for CRM Activities 

agrē can generate an .ics file that contains the information required for creating entries in most 
calendar software (like Microsoft Outlook, Google Calendar, and Apple iCal).  

The following information is included in the exported .ics file: 

• Next Reminder Date (or Activity Date if there is no reminder) 

• Description 

• Summary 

Calendar entries are exported from the Customer Activity window. 

 

 
Remember to save the export file on a drive that is available outside of agrē as 
you’ll need to access it from within your calendar software. 

Caution  Calendar information will be exported for ALL activities visible in the grid. 

Change the New Search criteria to display just the activities you want to 

export. 

Once the information has been exported from agrē, follow the instructions provided by your 
calendar software provider to import the file to create the calendar entries. 
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Employee Groups 

Employee Groups are used for filtering results of the CRM Activity Summary report.  

There are two steps to setting up Employee Groups: 

1. Add new Employee Group(s) 

2. Assign agrē users to an Employee Group 

 

Adding an Employee Group 

Navigate to Accounts Receivable > CRM > Manage > Employee Groups.  

Type a text label in the blank line at the bottom of the list and press TAB to activate. Save your 
changes. 

 

Editing an Employee Group 

To change the spelling of a group, double-click on the title and change the text. Save your 
changes. 

To deactivate a group, click on the checkmark in the Active column to remove it. Save your 
changes. 
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Removing an Employee Group 

If a group is not in use it can be permanently removed. If it has been used, you would need to 
edit every agrē user that has that group specified and select a different one (or remove it) 
before the group could be removed. 

Note You could also deactivate a group instead of removing it permanently. 
This may be a quicker option if it is currently in use, but you no longer 
need it. 

Select the attribute and click Remove Group. Save your changes. 

 

  



 

CRM – Customer Relationship Management  Page 31 of 46 

Assigning agrē Users to an Employee Group 

Employees are assigned to CRM Employee Groups through security settings. 

Navigate to File > Security > Manage Users. 

Select the user you want to add to a CRM Employee Group and click Edit. 

Choose the Employee Group and Save your changes. 
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Filtering Report Results by Employee Group 

After employees have been added to Employee Groups, you can filter activity lists by who 
created them. 

 

Run the CRM Activity Summary and Group By an employee group. 
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Document Manager 

The Document Manager allows you to organize all documents (attached PDFs, eSignatures, 
eDocs, emails, photos, etc.) from one central place. From here you can add, edit, delete, 
download, and view. 

 
File > Manage > Documents 

As well, customer documents can be managed from the customer account on the Documents 
tab … 

 
Accounts Receivable > Customer Accounts 

… and the last attached eDocument or eSignature can be viewed from the Account History tab. 
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The most recently attached eDocument or eSignature can be viewed also from its respective 
home form. 

 
Accounts Receivable > Work Orders 

Maximum file size that can be uploaded is 5 MB. 

The following types of documents can be uploaded:  

File Extension Built-in Viewer?  

.DOC Yes  

 

Not all documents types have a built-
in viewer.  

For those that don't, download the 
file and view it with the source 
application installed on your local 
computer. 

 

.DOCX Yes 

.DWF  

.GIF Yes 

.HTML  

.HTM  

.JPE Yes 

.JPEG Yes 

.JPG Yes 

.MSG  

.PDF Yes 

.PNG Yes 

.PPT Yes 

.PPTX Yes 

.TIF Yes 

.TXT Yes 

.XLS Yes 

.XLSX Yes 

.Z  

.ZIP  
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Searching for Documents 

As soon as you open the Document Manager (File > Manage > Documents) the default search 
screen opens. 

 
File > Manage Documents > Search 

Note eDocuments are included with agrē. 
eSignature is a premium module. 
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Adding a Document 

Note Adding a document from the Document Manager does not allow you to 
associate it with any particular customer or AR transaction. 

Click Add Document. 
The Upload Document window opens. 

Click Browse.  
The Chose a File to Upload window opens. 

 
File > Manage > Documents > Add 

 

Click Computer in the Navigation pane (left hand side of the window). 
Navigate to where the file is stored on a local drive on your computer, or on a local network 
drive. 
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From the File List pane (right hand side of the window) select the file to upload. 
Click Open. The Chose a File to Upload window closes and focus returns to the Upload 
Document window with the File to Upload field filled in with the filename you selected. 

 

Add a Document Title to easily identify the file contents. 
Keep it short and put the important part first as the column on the customer account is not 
quite wide enough to display all characters typed. 

 

Optionally add Keywords about the document. 

Check Sensitive if only users with "sensitive" security access should be allowed to view the 
document. 

Click Save to upload the document. 
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Save to Document Manager 

Instead of printing, scanning, and manually uploading, you can create a PDF copy of some agrē 
reports which saves it to the Document Manager directly, and links automatically to the 
transaction.  

Preview the report. Click the PDF more options arrow, then Save to Document Manager. 

 

Once the PDF has been saved to the Document Manager, agrē can close the report or leave it 
open. 

 

Adding a Document Manually to a Transaction Form 

Documents can also be added to certain transactions. For example, if a customer sent you an 
email regarding their prepayment plan for fertilizer, you could attach it directly to the relevant 
Work Order. 
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Documents attached manually to a transaction can be viewed from the usual places except they 
cannot be viewed from their respective home forms through the Preview Item button.  

 
AR > Customer Account 

File > Manage > Documents 
Individual Transactions (i.e. WO, LOT, INV, PMT, etc.) 

 

 
Accounts Receivable > Invoices 

If the most recent document was attached manually, eDocument and eSignatures will not be 
visible from the home form either. 
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Viewing a Document 

From the Document Manager, or from the customer account Documents tab, or from the form 
Documents window, select the document you want to view.  

 

Click View Item or View Document (depending on where you are). 
While viewing, you can also print the document by clicking on Print. 

 

Editing a Document 

Click Edit. 
The Edit Document Attributes window opens. 

Change the Document Title, Keywords, or Security. 

Click Save.  
Changes are effective immediately. 
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Downloading/Saving a Document 

Click Save As ... 
The Save As window opens. 

Note The default destination directory is on the agrē server.  
 
Remember to save the file in a folder on your local hard drive, or on a 
local network drive or you will not be able to access the file outside of 
agrē. 

 

Navigate to where you want to save the file and click Save. 
The Save As window closes. 

Deleting a Document 

Click Delete Document.  
The Confirm Delete window opens. 

Click Yes to delete the document. 
The Confirm Delete window closes and the document is deleted immediately. 

Note Deleting a transaction (Work Order, Loadout Ticket, etc.) does NOT 
delete automatically the associated documents! 
 
Delete the documents first, then delete the transaction. 
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Security for CRM 

CRM is a large module and there are several permissions items related to it. 

Note Security settings are managed by your local company security 
administrators. We don’t presume to know who should have access and 
who should not, so we leave that up to them. 

 

Managing Custom Attributes Security 

Navigate to File > Security > Manage Roles. 

By default any user who is allowed to edit a customer account will be allowed to edit Custom 
Attribute information on the CRM tab (except for the Credit group – that is secured separately) 
but you may want to restrict who can setup the attribute and group choices that appear in the 
dropdown lists. 

To allow permission to manage (add new, edit, remove) Custom Attributes and Attribute 
Groups: 

 
File > Security > Manage Roles > Permissions > Accounts Receivable 
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Credit Group Security 

Similar to the data on the customer account Credit/Finance tab, there is a separate permission 
to allow access to the Credit group on the CRM tab. 

To allow permission to edit the attributes in the Credit group on the Customer Account CRM 
tab: 

 
* not everyone may need this 

File > Security > Manage Roles 

 

Custom Attribute Export Security 

To allow permission to export Custom Attributes:  

 
File > Security > Manage Roles 

Note If a user does not have permission to view Credit group custom 
attributes, they will not be allowed to preview or export them either. 
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Managing CRM Activity Security 

To allow permissions to use and to manage (setup the dropdown lists) CRM Activities, and to 
allow permission to the Customer Activity window: 

 
* this is the Credit (Sensitive) permission, not everyone may need this 

File > Security > Manage Roles 

 

 

CRM Activity Reports 

To allow permission to view a single CRM Activity and the CRM Activity Summary Report: 

 
File > Security > Manage Roles 

Note If a user does not have permission to create Credit (Sensitive) category 
CRM Activities, they will not be allowed to view or print them either. 



 

CRM – Customer Relationship Management  Page 45 of 46 

Managing CRM Employee Groups 

To allow permission to create and manage Employee Groups: 

 
File > Security > Manage Roles 

 

 

To allow permission to manage agrē users so they can be assigned to Employee Groups: 

 
File > Security > Manage Roles 
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Security for Document Manager  

• Any user who is allowed to view a document will also be allowed to download it. 

• Sensitive permission is meant for documents that not every user needs to view. 

 
* not everyone may need this 

File > Security > Manage Roles 

 


