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FCL AGRĒ MATCH & MAP 

Now that your agrē database will be communicating with FCL’s mainframe (through a middle-man known 
as CRS Hub) they both need to be speaking the same language. For example, when you tell FCL that an 
agrē customer made a payment, CRS Hub needs to translate which FCL member matches up to your agrē 
customer Lyle Martin. 
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Overview 

If you were starting with a brand-new agrē database, you’d tell it to import FCL members for your retail, 
vendors, and items into your database from the master lists stored on CRS Hub and start business-as-usual 
from scratch. But you’ve been working with agrē for a while, so you’ve got existing customers, suppliers, 
and products already setup in your database and you don’t want to lose the history associated with them. 

That’s where the Match & Map tools come in - they create links in CRS Hub (that’s the middle man 
between your agrē database and the FCL mainframe) between the customers, suppliers, and products you 
already have in agrē to the master lists of members, vendors, and items on the FCL mainframe. The ones 
not already in your database can be imported as new. 

Before you start matching, Tronia will do a First Pass of your masterfile data (customers, products, and 
suppliers) to identify what you have, what’s been used, and what needs to be mapped. For example, you 
may have 10,000 customers in agrē, but have sold to only 3500. Rather than map all 10,000 customers, 
Tronia will delete the ones with no history so only the customers with activity remain. Then we’ll then do a 
Second Pass and automatically match and map as many customers as possible for you. To find a match for 
customers, agrē compares the agrē customer code, name, address, and phone number against the FCL 
Master Member List stored in CRS Hub. The customers that agrē can’t map automatically will need to be 
mapped manually by you. A similar process will be followed for suppliers and products. 

All customers must be mapped to FCL members, but it is not required that all suppliers and products be 
mapped to FCL vendors and items. 

 

Setup (one time tasks) 

Configuring agrēHub Settings 

Check the agrē Management Tool for the 
preferred overwrite settings. 

Check/uncheck the config items as required. 
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Security Permissions 
You’ll need permission in agrē before you can begin matching and mapping. 

 
File > Security > Manage Roles 
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Flagging the FCL Supplier (required for eOrders) 
You likely already have a supplier called Federated Co-op or something similar. You’ll need to edit that 
supplier (or add a new one if it doesn’t exist) and flag it as the FCL supplier so eOrders can be processed 
(eOrders can be submitted only for the supplier flagged as the FCL supplier). 

 
Accounts Payable > Manage > Suppliers 

SRP Price level 
An SRP Price Level must be set in order for agrē to use the FCL mainframe pricing data that is updated 
from CRS Hub.  

Check the box next to SRP Price Level and type a label for the SRP price.  

 
Inventory > Manage > Price Levels 

When determining prices, agrē goes through every other price level first and if no other price is found the 
SRP price is used. 
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Supplier/Vendor Mapping 
Let’s start with the easiest one so you can get the hang of it: mapping your existing agrē Suppliers to FCL 
Vendors.  

As agrē suppliers are mapped to FCL vendors, the agrē Supplier Code will be replaced immediately with 
the FCL Vendor Code. The old agrē Supplier Code is not retained. 

Mapping Vendors to Existing Suppliers 
Start the process by navigating to: 

 
File > Imports|Mapping > Suppliers 

Note To reduce the number you need to match, Tronia will delete suppliers that 
have no activity in your agrē database (don’ worry, they’re not gone for good - 
you can import them as new suppliers - with the mapping already in place – 
whenever you need them). 

Click Retrieve to view the list of FCL vendors.  

 

Tip Click Unmapped to view the list of unmapped agrē Suppliers. 
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On the left you’ll see the FCL vendors (every retail sees the same list of vendors) and on the right is where 
you’ll map to your agrē suppliers. 

 

Tips To jump down to the vendors starting with the letter “S” without scrolling, 
type “s” in the Vendor field and click Find. 
 
The grid can be sorted, for example by City, by clicking on a column header. 

Select Auto Map to search for agrē Suppliers that match FCL Vendors based on name and phone number. 

 

All matches found will have the Map column checked and the agrē Supplier selected. 
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Vendors that were not mapped automatically will need to be mapped manually. 
To assign a match, click the Map box to check it. 

 

To select a match in the agrē Supplier column either 

• click the down-arrow to select from the list of agrē suppliers 

• start typing the name of the supplier 

• type a letter or two, then click the down arrow 

Tip: Having the Supplier List data export open while you’re mapping vendors can 
make comparing details easier. 

 
File > Exports > Data > Accounts Payable 
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Saving the Mappings 

Once you’ve made your matches, Save them. You can map some suppliers now and save, then come back 
later and map a few more when you have time. 

 

Tip Click Unmapped to see which agrē suppliers are not yet mapped to FCL 
Vendors. 

After each Save, a message box appears telling you how many suppliers were mapped, unmapped, or 
imported. 

 

Each agrē Supplier can be mapped to a single 
FCL Vendor. If you accidentally map the same 
supplier multiple times, agrē will let you know. 
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Unmapping Vendors 
If you need to undo mapping to a vendor, just uncheck the Map box. The agrē Supplier field will be 
cleared automatically. Remember to Save the changes. 

 

Importing Vendors 
If there are FCL Vendors that are not in your agrē database but you want them to be, you can import them. 
Imported vendors are mapped automatically. Save the changes. 

 

Note You don’t have to import all the rest of the vendors right now!  
Just import the ones you need. 
 
Vendors can be imported anytime, not just during conversion. If you won’t 
order from a vendor until 6 months from now, you can import the new vendor 
then. 
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Customer/Member Mapping 
Next up is Member Mapping.  

As agrē customers are matched to FCL members, the existing agrē Customer Code and agrē Membership 
Number will be replaced immediately with the FCL Member Number (including check digit if applicable) 
stored in CRS Hub. The old agrē Customer Code and member number are not retained. 

 

Note To reduce the number of customers you need to match, Tronia will delete 
customers that have no activity in your agrē database (don’t worry, they’re 
not gone for good - agrē will import them soon as new customers with the 
mapping already in place). 

Once an agrē customer has been mapped to an FCL member you won’t be able to delete the customer in 
agrē unless you unmap them first. 
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Mapping Members to Existing Customers 
Start the member mapping process by navigating to: 

 
File > Imports|Mapping > Customers 

Automatic Mapping 

Tronia will have already automatically mapped most of your customers to the master member list in CRS 
Hub - but we don’t know your members as well as you do. Try using different combinations of the 
Automatic Mapping search criteria in case you can make some additional matches we weren’t able to see. 
For example, it may be quite obvious to you that agrē customer Belle Plain Farms should be mapped to 
FCL member Marc Adams. 

 

Tip Consider leaving the Results per Page at a workable number like 25, or you’ll 
be doing a lot of scrolling to see all the names on the same screen. Next takes 
you to the next group of 25, Previous takes you back. 
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Check the Map box if there’s a match. 

 

If all rows in the grid can be automatically mapped, click Select All. 
If there are more rows than can be shown on one screen, click Next to see the next group. 

Saving the Mappings 

Save the mappings as you go.  
Saving affects all the members retrieved, so you can map 300 at a time (click Next to see the next group) 
and then Save them all at once. 

 

Saving immediately overwrites the agrē Customer Code and the agrē Membership number with the FCL 
member number stored on CRS Hub. The old agrē Customer Code and the old agrē Membership Number 
are not stored or retained. Also overwritten with FCL mainframe information are the customer name and 
billing address (if you are in production mode). 

Starting Over 

Click Start Over to change which criteria boxes are checked and Retrieve a new set of data to match. 
Start Over clears the grid, and any mappings you’ve made, so you’ll want to save before you start over if 
you want to retain any mappings you’re made. 

 

All agrē customers must be mapped, so after you’ve made as many 
automatic matches as you can you’ll need to map the rest manually. 
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Manual Mapping 

To view your agrē customers who are not yet mapped select Manual Mapping and click Retrieve. 

 

You’ll see the list of unmapped customers and an empty column for selecting the matching FCL member 
from the CRS Hub master member list. 

 

To manually map an agrē customer to a CRS Hub Member 
(please refer to image on next page) 
• check Map next to the agrē customer you want to match 

• double-click the empty CRS Hub Member box next to the agrē Last Name 

• click on the dropdown arrow to bring up the master list of FCL members from CRS Hub 

• you can type a starting letter (eg. type S to jump down to the members whose names start 
with S) to scroll through the list faster 

• select the matching member 

• Compare the details to make sure you’ve got the right match 

• Save your changes 
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Once you’ve made a match, confirm you’ve selected the correct member by using Compare. 

 

For manual mappings you may find it helpful also to compare to the Member Master in CRS Hub. 

 
Data Management > View Master Data > Member 

Note Data in CRS Hub grids can be manipulated just like the grids in an agrē data 
export: sort by clicking on a column header, group by dragging a column 
header into the dark grey area, put columns in a different order by clicking and 
dragging. 
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Unmapping Members 
If you need to undo member mapping, select Undo Mapping and click Retrieve. 

 

Check the Undo Mapping box for each customer that you want to unmap or click Select All to check all 
Undo Mapping boxes in the window at once (click Next to view the next 25 mapped customers if you want 
to unmap them too). When you’re done, Save your changes. 

 

What about the rest of my members? 
What about the grocery, HABs, and Petro members from your retail, the ones you haven’t sold agro 
products to and so weren’t setup as customers in your agrē database? 

The first time your agrē database communicates with CRS Hub and processes the initial automated 
Member Update, all those customers will be automatically downloaded (already mapped) into agrē.  
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Product/Item Mapping & Importing 
There are two kinds of items/products in agrē. 

Mapped Items are products that exist in your agrē database and in CRS Hub, and are linked to FCL Items 
on the mainframe. These products are mapped in order to process eOrders, and to receive data updates and 
pricing information from the FCL mainframe. 

Retail-created Items/Products are added like you’ve always added a new product and exist in your agrē 
database only. These products are maintained wholly by your retail. Retail-created products are not 
mapped. 

Mapping FCL Items to Existing agrē Products 
Navigate to File > Imports|Mapping > Map Products. 

 

The first step is to use Quick Search to search for products in your agrē database. Quick Search checks all 
or part of: Product Description, Product Code, Short Description, UPC, or Manufacturer Product Code, 
Supplier Alternate Product Code, and Brand.  
You can also choose to filter by Product Type or Product Group. 

 
File > Imports | Mapping > Map Products 
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Note To reduce the number of products you need to match, Tronia will delete 
products that have no activity in your agrē database (don’t worry, they’re not 
gone for good – you can import them soon with the mapping already in place). 

The second step is to look for matching FCL items for your agrē products. agrē assists with this task by 
suggesting matching items. One, some, or all of the Suggestions can be checked. 

The item matching suggestion options include: 

• agrē Product Code = FCL Item Number 
• agrē Manufacturer Code = FCL Item Number 
• agrē UPC(s) = FCL UPC(s) 
• agrē Product Description = FCL Item Description 
• also suggest Delete/Deplete FCL Items 

 

Click Load Suggestions to find matching FCL Items. 

As there are tens of thousands of FCL items to check for a match, this could take a minute or three 
especially if your internet connection isn’t lightning-fast. There is a progress bar to indicate the status of 
the suggestions process.  
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Once the suggestions have loaded, you can confirm you’ve got the right match before it’s mapped. Select a 
product with a suggested item and click Mapping Details. 

 

This should give you enough information to confirm if the suggested item is indeed a match. 

 

If the item is a match, check the Map box. If it’s not a match, leave the box unchecked. Optionally leave 
checked Overwrite Product Code with FCL Item Number to replace the agrē product code (the existing 
Description will remain either way but can’t be edited once mapped; UPC Codes are not overwritten in 
Setup mode). 
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Once you’ve made some matches, save the mappings. 

 

If you’ve checked items to Map, then subsequently used a column filter to refine the list of products you 
see, and at least one of the checked products is hidden by the filter, agrē warns you the hidden products will 
not be mapped. agrē will map only the items you can see. 

 

Note When an agrē product is mapped to an FCL Item and there is a corresponding product type 
where the external product type code matches the category, the Product Type is updated 
automatically to match. 
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There may be an FCL Item that is almost a match to an agrē product, but the agrē product needs a change 
or an addition before it can be mapped. An example of this would be an agrē product that is missing a 
proper unit type match to an FCL Item. Click Edit Product to make the appropriate changes that will make 
it an exact match. 

 

There will likely be agrē products that don’t have suggested FCL Items. Search Items lets you search 
manually to find a match from the FCL mainframe.  

 

Add Filter Items criteria and click Search Items (or press Enter) for matches. Select the item that matches, 
click Map (or double-click the item). 
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Again, if you’re not sure you can check the Mapping Details to confirm it’s a match before you map.  

Confirming Mapped Items 

You can double-check which products have been mapped from the Manage Products home form … 

 
Inventory > Manage > Products 

… and from the Product List data export. 

 
File > Exports > Data | Inventory | Product List 

SRP Pricing for Mapped Products 

SRP Pricing will be downloaded for each mapped (and re-mapped) product, but you won’t see the pricing 
until tomorrow after the agrē sweeper runs overnight and moves the pricing information to the product. Not 
all FCL items have prices stored on the mainframe so you will likely need to set at least some of your own. 
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Unmapping Items 
If an error was made – maybe a product was mapped to the wrong item, or the Units were incorrect, you 
can unmap a product easily. 

Filter Products using criteria that will list the mapped products and check Include Mapped before clicking 
Search. Select the product you want to unmap, uncheck its Map box, and Save. 

 

 

You’ll see a message on Save telling you how many products were mapped and unmapped. 

If you’ve unchecked items to Unmap, then subsequently used a column filter to refine the list of products 
you see, and at least one of the unchecked products is hidden by the filter, agrē warns you the hidden 
products will not be unmapped. agrē will unmap only items you can see. 

 

  



FCL agrē Match & Map  Page 23 of 29 

Importing FCL Mapped Items 
FCL items that don’t already exist in your database can be imported from the FCL mainframe via CRS 
Hub. 

Selecting Items by Retail 

Before you start importing items, you’ll want to 
confirm which categories of products you will 
want to import. There literally tens of thousands of 
FCL items available for import, so pre-filtering by 
category means you won’t have to wade through 
thousands of items you are never going to use. 

Navigate to Inventory > Manage > Item 
Categories (CRS Hub).  

 

Tronia refers to this chart as a “tree” with many 
“branches”. Click the + and – buttons to expand 
and collapse a branch. 

Check the boxes next to the item branches you’ll 
be importing. 

Only items from selected branches will be 
available for import.  

Example: your retail sells seed, but not soybean 
seed. Check SEED (to select all seeds) then 
uncheck SOYBEAN. You won’t see any soybean 
seeds listed among the other seeds when you 
retrieve items for import. 

Save when you’re done. 
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Importing Items 

Now that you’ve selected and saved your tree branches, you can start importing items either individually or 
in batches (a maximum of 500 items can be imported at one time). Products can be imported any time in 
the future too so you can import just the ones you need now, and import more later as required. 

Navigate to File > Imports|Mapping > Import Products. 

 

When filtering for items to import you’re going to want to be a little more specific than “show me 
everything available” or you’ll be waiting in front of your computer for a really long time for all items to be 
retrieved – there are well over 10,000 available for import. 

Use the Filter Items to narrow down the number of FCL items that Retrieve Items will bring back. 
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By default the results in the grid are sorted by Description. You can sort the data by another column by 
clicking on its header. Click again to sort the other way. 

 

 

 

agrē retrieves all items from the FCL database 
that match the Filter Items - which could still 
be a large number.  

You can further narrow down the list of items 
by applying column filters. 

 

 

To clear a column filter, expand the column 
filter window again and choose Clear, or 
click Start Over (located at the top of the Import 
Products window in the title bar). 
  

 

If you had selected any items before you applied a column filter, those items will still be selected (even 
though they are hidden because of the column filter) but only the ones you can see will be imported. 

 

If you want to import all the items selected, clear the column filter to display all the selected items again. 
agrē will import only the selected items that are displayed - if you can’t see them agrē won’t import them. 
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1. Select items by checking Import. 
Click Select All to check all items retrieved (maximum of 500). 

2. If importing a single item and no Smart Links were found, specify the Product Type, Unit Type 
(this should match the FCL Shipping Unit), and GL accounts for the item selected.  
These fields must be specified as they are required fields in agrē – you wouldn’t be able to 
manually add a new retail-created product without them either. 

3. If importing multiple items, in the Product Update section specify the Product Type, Unit Type 
(this should match the FCL Shipping Unit), and GL accounts for the item(s) selected. 
Click Update Selected to copy the Product Update settings down to all the blank fields in the 
selected item lines at once. 
Exceptions to the Product Update settings can be selected on the same line as the selected product 
(and will not be overwritten). 

4. Click Import. 
The items selected are imported into agrē as mapped products.  

 

 

 

Tip To see at a glance which products are Mapped (as compared to which are 
Retail-Specific) run the Inventory Product List data export (File > Exports > 
Data). Only products with an item number, category, and category description 
are mapped. Sorting by Item Number groups the mapped products together. 
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Imported Item Pricing 

SRP Pricing is imported with the item, but not all mapped items have prices stored on the FCL mainframe 
so you will likely need to set at least some of your own. 

 
Inventory > Manage > Products > Prices/Taxes 

SRP could be for all, some, or no Locations and for all, some, or no Unit Types. 
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Imported Item Taxes 

FCL does not send tax information along with the item when it’s imported. 

 
Inventory > Manage > Products > Prices/Taxes 

If you are changing the default GST/HST or PST tax settings of a mapped items with FCL pricing you must 
first select Retail Managed Taxes . 

Products flagged with Retail Managed Taxes will NOT receive any GST/HST or PST updates from the 
mainframe so your custom settings will NOT be overwritten during the nightly sync with mainframe. 

Products of the following types are flagged automatically as Retail Managed Taxes: 
• Feed (2055) 
• Food (30) 
• Energy (60) 
• Fertilizer (70) 

Products flagged with FCL Managed Taxes WILL receive updates to GST/HST and PST from the 
mainframe so any changes you make WILL be overwritten during the nightly sync. 
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 Editing Mapped Products/Items 

 
FCL Item Details displays all the FCL information 

When you edit a mapped item, there will be some fields that you can’t change. These are the fields that are 
managed on the FCL mainframe and are identified by a grey background.  

All other fields are fair game. Don’t like the product code? You can change it! Decided to use a different 
Sales GL? You can change that too. You won’t be able to delete the FCL each/shipping unit on the Units 
tab but you can add additional ones and change the main unit type.  

You can add characteristics, supplier codes, etc. but don’t feel like you have to fill in every field right now. 
Just like when you started using agrē initially you can add details as you go. There are some exceptions. If 
you import a new blend commodity item, you’ll need ensure it’s flagged as Blendable and add the nutrient 
info on the Blending tab or you won’t be able to add it to a blend. Fertilizer Act and Permit details may 
need to be entered on the Regulations tab too. 

Imported items receive the same updates from the FCL mainframe as mapped items, but any information 
you’ve added yourself will not be overwritten. 
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