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agrēMOBILE 

 

In the office or off the grid, agrēMobile lets you record Field Scouts on your mobile device from wherever 
you happen to be.  
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agrēMobile allows you to update your Customer’s records on the go. It includes features such as: 

• Add/Edit Customer Field Scouts 

• Maintain a list of growers you work with often 

• Track your location in real time on the map and add Photos and Markers  

• Email your growers from within the app  
Send detailed scout reports with information about their Farm Fields 

• Work offline & sync when reconnected 

Notes agrēMobile requires an active agrē login, as well as access to the agrē 
Agronomy Module with security permissions.  
 
If you have questions, please contact your local agrē administrator.  
If you are the local agrē administrator please contact support@tronia.com 

agrēMobile is a live link to your hosted agrē database. Any data that is entered through agrēMobile will 
immediately be updated in your agrē system. This does mean you will require a wifi or data (3G, 4G, LTE, 
5G) connection to login, but agrēMobile also has offline capabilities so you can work when you’re off the 
grid and sync to agrē later when you’re back online.  

Features indicated with the online icon  are available only when connected. 

 

 

Help More detailed information about Field Scouts can be found in online Help. 

 
Help > Help Topics 
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agrē Setup 
Before you head out into the field, agrē has a few configuration options that can help agrēMobile work 
more efficiently. 

To activate Config Option changes: logout of agrēMobile and login again.  
You may also need to Refresh Data (see page 8) from the Side Menu. 

 

 

Company Config Options 

Agronomy 

 
File > Config Options > Company > Agronomy 

Filter Mobile Retrieve Products by Type  If all the products you recommend on Field Scouts are from 
the same product type (e.g. Chemicals) you can specify that agrēMobile should download only those items 
to your mobile device. This saves storage space on your device, and decreases download time. 
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Automatically generate Reference Number  agrēMobile will always default to autogen - just one less 
thing you have to type yourself. Don’t forget to setup a starting Field Scout Number if you haven’t done 
that yet. 

 
File > Manage > Reference Numbers > Agronomy 

Image File Size  Small is plenty big enough to print on reports. Transferring a small file from your mobile 
device to agrē takes less time and uses less bandwidth. 

 

 

 

 

Email Defaults 

 
File > Config Options > Company > Reports > Email Defaults 

Emailed Reports are sent from  agrēMobile will use this address as the backup sending address when 
emailing scouts to growers if no user address is entered.  
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User Config Options 

Email 

 
File > Config Options > User > Email 

Email address  (strongly recommended) agrēMobile will use this address as the default sending address 
(the “from address”) when emailing scouts to growers.  

CC or BCC  Check if you want a copy of all emails sent to the sending address by default. 

Email Body Default for Attachments  Default text that appears on the Send Email window (can be 
changed on the fly). For scouting, [REPORTNAME] = “Field Scouting”. 

Attached Filename Default  Select how to name the attached scout report. 
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Customer Accounts 

Default Customer Email Addresses 

Email Addresses  Enter grower addresses in advance to save time (and improve accuracy) in the field by 
not having to type each one on the fly as you send a scout. 

 
Accounts Receivable > Manage > Customers > Customer 

If Email Address(es) (#1) is blank, agrēMobile will default to Company Email (#2). 
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Installing agrēMobile 
agrēMobile is installed from your device’s app store. You do require an active store account to login, but 
you don’t need to have your credit card handy; agrēMobile is free. 

Use these links to take you to the install page … 

   

…or search the store for agrēMobile or Tronia. 

  

App Permissions 
While using the app, some features will prompt you to allow access your device’s resources. 

 

• Photo and Media permission is required to take photos 
with your camera and store them on your device so they can 
be attached to scouts 

 

• Location permission is required to use GPS for mapping, 
markers, and “follow me in real time” 

https://play.google.com/store/apps/details?id=com.tronia.agremobile
https://itunes.apple.com/ca/app/agr%C4%93mobile/id1382855464?mt=8
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Login/Logout 

You must be online/connected  to the internet in order to login to and logout of agrēMobile.  

The agrēMobile login screen is displayed. 

 

To Login  

• there’s no Citrix involved with mobile apps so 
you won’t need your 
tslEdmonton1@tronia.com ID 

• login with your agrē user ID … 

e.g. tslagreuser 

• … and your agrē user password 

• tap Sign In 

 
 
 

 

To Refresh Data  

• tap the “hamburger button”  at top left to 
reveal the Side Menu  

• tap Refresh Data to update your local device 
cache with new data (new Customers, Fields, 
Products, Weeds, Pests, Diseases, Scout Types etc.) 

To Logout  

• tap the “hamburger button”  at top left to 
reveal the Side Menu  

• logout by selecting Log Off 
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agrēMobile Home Screen 

 

• here you’ll find your list of Favourite 
Customers (see Customer Home to add 
them), and any Unsynced Items not yet saved 
to agrē  

• tap Find Customers to launch the Find 
Customer screen 

 

 

Finding Customers 

 

• use the Find Customer filter at the top to 
search by either Name or Customer Code  

• tap a name to open their Customer Home 
screen 



 

agrēMobile  Page 10 of 20 

Customer Home Screen 

 
 

• the Customer Home screen is where you add 
new activities or edit existing ones for the 
grower you selected 

• you can call (tap the phone number) or email (tap 
the email address) the grower directly from this 
screen 

• tap Fields to see a list of the grower’s farm 
fields (number of fields shown in brackets) 

• tap  to add this grower to your list of 
favourite customers list (tap again to remove them) 

• tap Add Field Scout to start a new scout  

• tap an existing scout to Edit  the activity or 

to Email  the scout report 

Customer Fields 

 

 

• the Customer Fields screen is where you add 
new farm fields or edit existing ones for the 
grower you selected 

• tap Add Field  to add a new field 
(you must be online to save) 

• tap an existing field  to modify its details  
(you must be online to save) 
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Adding a New Field 

 

• you must be online to save a new field 

• a Field Name* is required 

• Legal Land Description, Acres, Comments, 
Ownership, and Irrigated are optional 

• tap Save Field  when complete 

• tap OK to acknowledge the message 

 

 

• the Fields count is updated and the new field 
displayed 

• the new field also appears in your agrē 
database immediately 
 

 

 

 

Adding Field Scouts 
agrēMobile simplifies the way you enter Field Scouts with mobile devices - it allows you to more easily 
record scouting details while on the go. The data that you gather with agrēMobile is the exact same as 
desktop agrē – we just simplified the interface to give you a more streamlined workflow.  

Field Scouts can also be started in agrē before you leave your office, then edited  in 
agrēMobile in the field. You can make more updates in agrē if needed when you return. 
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Adding a New Field Scout 

 

• scouts can be added when offline, then synced 
to agrē when you’re connected again 

• from the Customer Home screen, tap  
Add Field Scout 

 

  Scout tab 

• adding a Field Scout starts on the Scout tab, 
required fields are indicated with a * 

• more than one Farm Field* can be selected 

• Enter Time is optional but can be nice to have 

• turn on Enter Reference to enter your own 
number; leave off for auto-numbering 

• Crop* and Variety default  to those on the 
current crop plan (can be changed) 

• Stage can be typed, or selected using Find 
(crop-dependent, selected stage text can be edited) 

• Previous Crop defaults  to the crop from 
last year’s crop plan 

• tap Save Scout to save at any time and return 
to the Customer Home screen 

 

• tap Get Location to use the GPS on your 
device to pinpoint your location 
(allow permission for agrēMobile to use your device’s 
location if prompted - accuracy varies, depends on the 
GPS hardware installed in your device, if data/wifi is 
active, cloud cover, etc.) 
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  Details tab 

• tap the Details tab to add:  

• Weeds 
• Insects 
• Diseases 

 

Tip  your device’s keyboard may cover 
the  Add  button - close the keyboard so you 
can tap it 

 

 

• Details are listed in the order they were entered 

• on Save of the scout they will be grouped by 
category (so when you come back later and 
edit, all the weeds will be grouped together) 
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  Products tab 

• tap Find Product to search for and select 
recommended items 

• check Enter Rate and Quantity* will be 
calculated based on the number of acres of the 
Farm Field selected on the Scout tab 

• uncheck Enter Rate to enter a Quantity* 
manually 

 

 
 

 

 

• products are listed in the order added 
(sort order can be changed manually in agrē later if 
needed) 
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  Images tab 

• tap Add Picture to add photos or pictures to 
your scout 

 

 

• tap Take new Image to use the camera on 
your device to take a photo (allow permission 
for agrēMobile to use your device’s camera if 
prompted) 

• Android: photos are also saved to the 
device’s gallery 

• iOS: saving photos to the device’s gallery is 
not supported  
iOS Tip  Take the photo using your device’s 
camera app (so there’s a copy saved locally), 
then add to scout from the gallery. 

• tap Add from Photo Gallery to attach a photo 
already taken 

 

• add a Description* of the image  
(can be edited at any time) 

• check Add to Map to automatically create a 
Scout Marker with your current coordinates 
(accuracy varies - depends on the GPS hardware installed 
in your device, if data/wifi is active, cloud cover, etc.) 

• type any additional Marker Information 
• tap the map Marker icon you want to link 

to the photo  

• Scout Markers are associated only with this 
Field Scout Map (and will not appear on the 
main Farm Field map)  
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  Map tab  (online only) 

• if prompted, allow agrēMobile to retrieve your 
current location if you want to use all 
functionality of the scout map 

• if the selected Farm Field has a map it will be 
displayed 

• tap the Compass  to move the map to your 
current position 

• your current position will be indicated by a 
blue dot  which will follow you in real 
time as you move about the field  
(when offline the dot will follow you, but you 
won’t see the map) 

• tap Add Marker  to add a scout marker 
with your current coordinates (displayed only 
on this scout’s map) 

• touch and drag to move a marker 
• tap an existing marker to view 

associated photos and/or additional 
information 
 

• poor connectivity, cloud cover, etc. can slow 
the map refresh rate 

 

 

Saving 

 

• Save Scout when you’re done (or any time you 
want to save your changes)  

• tap Email  to send the Scout Report and 
return to the Customer Home screen 

• tap OK to return to the Customer Home 
screen without emailing 

 

• scouts saved online  appear on the 
Customer Home screen 
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• scouts saved offline appear on the main  
Home screen under Unsynced Items 
 

Emailing (online only) 

 

• the From address comes from your agrē User 
Config Options Email tab (see page 5)  

• the To*address will default to the customer’s 
email address (if specified on the customer’s account 
in agrē, see page 6 - if not, you’ll need to type an address 
on the fly)  

• default Subject and Body text can be changed 

• Send  will generate an Email and attach a 
PDF copy of the Field Scout report (including 
markers and photos if you added them) 
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Editing an Existing Scout  
Unless you just saved it offline and it’s still stored on your device listed under Unsynced Items, editing 

Field Scouts requires wi-fi or data connectivity .  

 

• from the Customer Home screen, tap an 
activity 

• tap Edit 
(you can Email  from here too) 

 

 

Using agrēMobile Offline 
agrēMobile has the ability to save your Field Scouts offline. When the application detects that you have a 
connection, you’ll be able to sync your offline items to your agrē database. 

How does it work? 

All you need to do is login  to agrēMobile before you go offline. While you are still connected, login to 
agrēMobile as you normally would. 

When you connect to the internet and login, agrēMobile saves a copy of the data on your device. Included 
in that local copy is all the data needed in order to do lookups in agrēMobile while offline. Examples are 
the lists of Customers, Products, Weeds, Diseases etc. When the app has access to a connection this data is 
updated automatically every 3 days, or you can Refresh manually (see page 8) so you always have the most 
recent data available. 
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You will notice that some functions are not available when offline. For example, editing a Field Scout is 
not an option (unless it was saved offline to your device). This is because agrēMobile would need to access 
the existing Field Scout from your agrē database in order to edit it, but you’re not connected so it can’t be 
loaded.  

Online-only agrēMobile features  include:  

• login/logout 
• edit scout not saved offline on device 
• field maps 
• email 

What happens to the activities I saved? 

 

• activities saved while you’re offline are stored 
on your device 

you may see a Network Error message -  
it’s ok, you know you’re offline 

 

 

• you’ll see them listed on the Home screen 
under Unsynced Items 
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How Do I Synchronize when I’m Back Online?  

 

• login  to agrēMobile  

• to sync all Unsynced Items 

• tap Sync All  
 

 

• to sync just one Item  
• tap the activity 

• tap Sync  

• if there are Items you do not want ever synced 
• tap the item 
• tap Delete (just the local copy will be 

permanently deleted) 

 

 

• (optional) tap the “hamburger button”  at 
top left to reveal the Side Menu then … 

• … tap Refresh Data  to update your local 
device cache with new data (such as new 
Customers, Fields, Products, Weeds, Pests, Diseases, 
Scout Types etc.)  

Note: If you have any questions or require further assistance with agrēMobile, 
please contact support through your usual channel. 
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