
   

Last Updated: 2022.09.08 

CHEQUE/EFT BATCH PAYMENT REVIEW PROCESS 

Overview 
The Cheque/EFT Batch Payment Review Process - also known as the AP Payment Approval Process - is 
used when you want supplier payments to be reviewed before the cheques are printed or the EFT files are 
generated for submission. Using the Cheque/EFT Batch Payment Review Process in agrē is optional. 

When using the Cheque/EFT Batch Payment Review Process payments are made to suppliers, then 
individual payments are grouped into a batch. A Cheque/EFT Approval report is created and used during 
the manual review process. Until the batch is approved, the payments will not appear on the Print Cheque 
window and cannot be selected for printing, or if they are EFT payments they cannot be added to EFT 
Payment Batches so no EFT data file can be generated. Once a batch has been reviewed and approved, the 
payments appear in the Print Cheques window and can be printed and the EFT payments can be added to 
EFT Batches. 

Using the Cheque/EFT Batch Payment Review Process also changes the way that you can cancel 
payments in a pending batch. A pending payment must be cancelled from within its batch and cannot be 
cancelled from the supplier’s account. 
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One-Time Tasks 

Company Config Options 

Accounts Payable Tab 

You'll need to activate the company configuration option before you can start using the Cheque/EFT Batch 
Payment Review Process. 

Tip It’s a best practice to have all cheques printed and all EFT batches submitted 
before turning on the payment review process config item as it affects NEW 
payments only.  
It has no effect on existing payments (so the cheques for existing payments 
could be printed by anybody with permission to print cheques). 

To configure the Cheque/EFT Batch Payment Review Process: 
• Navigate to File > Config Options > Company. 

The Company Level Settings window opens. 

• Navigate to the Accounts Payable tab. 

• Check the box next to Use Cheque/EFT Approval Process in the Supplier Payments section. 

 
File > Config Options > Company > Accounts Payable > Payments 

• Click Save. 
The Company Level Settings window closes. 

If this config item is not checked most elements of the Cheque/EFT Batch Payment Review Process can 
still be used but you’ll be able to print the cheques or generate an EFT batch immediately as there is no 
enforced approval process. 
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Messages Tab 

agrē can automatically send a message notification to users when a batch has been approved so that they 
know there are cheques ready to be printed. 

To configure the approval notification role: 
• Navigate to File > Config Options > Company. 

The Company Level Settings window opens. 

• Navigate to the Messages tab. 

• In the drop down field next to Cheques have been approved select the role of users that will receive 
the notification message. 

 
File > Config Options > Company > Messages 

Note Cheques is just a short cut label for “Cheques/EFTs”. agrē will send a message 
for all approved payment batches, even if they contain only EFTs. 

• Click Save. 
The Company Level Settings window closes. 

Starting Batch Reference Number 
Payment batches must have unique reference numbers. If you'd like agrē to auto-number the batches, 
specify the starting number and an optional prefix for each batch. If you are going to use your own manual 
sequence of batch reference numbers, you can skip this task. 

To setup the starting batch reference number: 
* denotes a required field 
• Navigate to File > Manage > Reference Numbers > Accounts Payable. 

The Manage Accounts Payable Reference Numbers window opens. 

• Navigate to the Company Wide tab. 

• In the Cheque/EFT Approval section, specify the batch prefix (optional). 
Specify the first Batch Number.  
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File > Manage > Reference Numbers > Accounts Payable 

• Click Save. 
The window switches to Location Specific tab. 

• Click Exit. 
The Manage Accounts Payable Reference Numbers window closes. 

 

 

 

Security Permissions 
Security permissions need to be allowed for both Batch-Makers and Batch-Approvers. 

Cheque/EFT Approval & Reporting permissions  

Batch-makers and Batch-approvers require different permissions. 

To allow payment batch creation permission: 
• Navigate to File > Security > Manage Roles. 

The Manage Roles window opens. 

• Select the appropriate role and click Edit. 
The Edit Role window opens. 

• Navigate to the Permissions tab, then to the Accounts Payable subtab. 
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• Next to the Cheque/EFT Approval item, check Allow for the following items: 
for batch-makers:  Add, Edit, Delete, Enable on menu 
for batch-approvers:  Add, Edit, Delete, Enable on menu, Approve 

 
File > Security > Mange Roles 

• Next to the Report - AP Cheque Approval item check the Allow? box. 
Both batch-makers and batch-approvers may want to run this report. 

 

Note Remember “cheque” is just a shortcut label for cheque/EFT. 

• Save your changes. 
The Edit Role window closes. 

• Exit the Manage Roles window. 
The Manage Roles window closes. 
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 Combined Batch-Maker/Batch-Approver Shortcut  

If there are users who are allowed to both create batches and approve them (a.k.a. Approval Process 
Skippers), you can allow them to skip the whole Cheque/EFT Batch Payment Review Process and go 
directly from making the payment to printing the cheque or creating the EFT batch (just as if there was no 
approval or review required). Any payments the user makes will be flagged as Approved on creation. 

Payments made by Approval Process Skippers can still to follow the regular approval process (create the 
payments, create an approval batch, approve it themselves, print the cheques/create the EFT batch) but they 
don’t have to. 

Note This security item affects only NEW payments made after the security item has 
been changed; it has no effect on payments that have already been made. 
Existing payments were already flagged as Approved or Not Approved when 
they were created. 

To allow batch-approvers to skip the Cheque/EFT Batch Payment Review Process: 
• Follow the steps above to grant permission to all the Cheque/EFT Approval items. 

They’ll still need those permissions to approve other users’ batches. 

• Next to the Make Payments item, check Approve. 
This tells agrē that whenever this user creates a payment, consider it already approved. 

 

• Save your changes and Exit the Manage Roles window. 
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Cheque/EFT Batch Payment Review Process Outline 

Pay the Suppliers 
• Run the Suggested Payments Report to identify which purchase invoices are outstanding and need to be 

paid. 

• Follow your standard agrē Make Payments process.  
Payments (flagged as not approved) are created, credits applied, and postings made to the GL. 

• The purpose of making payment and applying credits is to lock the PI from any further changes while the 
payment review process is happening. 

Note: All GL postings are made at the time of payment. 
The approval process and printing of the actual cheques (or submitting an EFT 
batch to your bank) has no effect on the GL. 

 

 

Create the Cheque/EFT Approval Batch 

Note  As Canadian banks can process EFT payment batches comprised of a single 
currency only, each EFT batch must be limited to one type of funds. 

Create a new payment batch by adding the not-yet- approved payments.  

To create a new cheque/EFT batch: 
* denotes a required field 
• Navigate to Accounts Payable > Supplier Payments > Cheque/EFT Approval. 

The Cheque/EFT Approval window opens. 

• Click Add to create a new batch. 
The Add Cheque/EFT Approval Batch window opens. 

Note If you want to use a manual reference number for this batch, uncheck the box 
next to Generate Reference Number and type one. 

• Add any Comment about this batch if needed. 

• Click Retrieve Payments. 
The Payment Search window opens. 
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• Click Search  
- or - 
Optionally change the criteria and then click Search. 
The Payment Search window closes and all payments that meet the criteria are listed in the grid. 
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• Check the Include? box next to all payments you want added to the batch. 

 

Caution Depending from which location the cheques will be printed and whether you 
have agrē print the cheque numbers on the paper cheques, you may or may 
not want to include payments from multiple locations in the same batch. 

• Save the batch. 
The Preview Batch window opens.  

• Optionally preview and print (or PDF) the Cheque/EFT Approval report when prompted.  
The status of the batch is Pending Approval.  
Exit the report. 

Tip If you said No to the print prompt and then change your mind, select the batch 
on the Cheque/EFT Approval window and click Preview Item. 

• The batch is listed in the Cheque/EFT Approval grid. 

 

Note You will be unable to print the cheques before the batch has been approved. 
Only approved cheques will appear in the Print Cheques window. 
 
You will not be able to add unapproved EFT payments to EFT Batches either. 

http://www.tronia.com/webhelp/AP/EFT_Payments.htm
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Review the Cheque/EFT Approval Report 
• Once the Cheque/EFT Approval report has been created it is manually reviewed outside of agrē using 

your company’s approval process.  

 

 

Approve the Batch 
• After reviewing the Cheque/EFT Approval report, if everything is good to go and the cheques can be 

printed or the payments added to an EFT batch, the batch can be approved in agrē by a user with the 
appropriate security permission. 

To approve a cheque batch: 
• Navigate to Accounts Payable > Supplier Payments > Cheque/EFT Approval. 

The Cheque/EFT Approval window opens. 

• If you don’t see the batch you want listed, click New Search and change the search criteria. 
Click Search. 

• Select the batch to approve and click Edit. 
The Edit Cheque/EFT Approval window opens. 

• For any payments you don’t want to approve at this time, uncheck the Include box.  
Unapproved payments will be removed when the batch is saved, and can be added to new batches. 

 

• In the Approval section, check the box next to Approved By. 
Your agrē user name will appear in the text box and the payments grid will be greyed out.  

 

Tip You cannot add additional payments or remove any existing payments from an 
approved batch.  
 
If you need to make changes, edit the batch, uncheck Approved By, make the 
edits, then check Approved By again and save the batch. 
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• Save the batch. 
The Preview Batch window opens. 

• Optionally preview and print (or PDF) the Cheque/EFT Approval report.  
The status of the batch is now Approved. Exit the report. 

• The batch is flagged in the Cheque/EFT Approval grid as Approved. 

 

Notes Now that the batch has been approved those cheques will appear in the list on 
the Print Cheques window, or can be added to EFT batches. 
 
Approved batches cannot be edited and neither can their respective Purchase 
Invoices. 
 
Payments in approved batches can be cancelled. Cancelled payments are 
automatically removed from the batch. 

• Changing the status to Approved will trigger the automatic notification message to be sent to specified 
users that AP Payments have been approved for further processing (this is setup on the Messages tab of 
Company Config Options).  

 

 

Tweak the Batch before Approving 
• If the batch is not quite ready for approval yet, Edit the batch and Save your changes instead of 

approving it right away.  

• Print a new Cheque/EFT Approval report for an additional manual review cycle. 

Tip If you’ve already approved a batch and then need to edit it, uncheck the 
Approved By box, make your changes, then Approve again and Save. 

• This process may occur numerous times before a batch is ultimately approved. 
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Cancelling a Payment in a Pending Batch 

Caution Cancelling a payment is still cancelling a payment!  
 
If you want to remove a payment from a pending batch (maybe so you can 
add it to a different pending batch), just uncheck the Include? box next to 
the payment and save the batch. 

Because a pending batch “locks” its payments, a pending payment can be deleted only from within the 
batch. Payments can be cancelled only from Pending batches. 

To cancel a payment in a pending batch: 
• Navigate to Accounts Payable > Supplier Payments > Cheque/EFT Approval. 

The Cheque/EFT Approval window opens. 

• If you don’t see the batch you want listed, click New Search and change the search criteria. 
Click Search. 

• Select the batch to approve and click Edit. 
The Edit/EFT Cheque Approval window opens. 

 

• Select the payment and click Cancel Payment. 
The Confirm Cancel Payment window opens. 

• Click Yes to confirm. 
The Confirm Cancel Payment window closes, the payment is cancelled immediately, and it is 
removed from the batch. 

• Save the batch. 
The Preview Batch window opens. 

• Optionally preview and print (or PDF) the Cheque/EFT Approval report.  
Exit the report. 
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Getting the Funds to Your Suppliers 
Once the payments have been approved, take the next steps to get the payment to the supplier. You will 
either print cheques, or create an EFT payment batch that contains all the information your banks needs 
transfer funds from your bank account directly to the suppliers’ banks accounts. 

Print the Cheques 
Printing cheques will occur by batch and will include any optional electronic signatures. 

To print a batch of cheques: 
* denotes a required field 
• Navigate to Accounts Payable > Print Cheques. 

The Print Cheques window opens. 

• Choose the Location* and the Payment Type*. 

• Confirm the Starting Cheque Number*. 

• Click Select Batch and choose the appropriate batch of payments. 

• Click Prepare Cheques. 
Payments from the batch will appear in the grid. 

• Check the Print checkbox next to each cheque that you want to print. 

Caution If you let agrē autogen your cheque numbers and you have payments for 
multiple locations in the same batch, you may want to print the cheques for 
each location separately. This ensures that the cheque reference numbers 
will follow the proper sequence for their respective locations. 

• Click Print to print the cheques. 

• Click Save when all cheques printed successfully. 

• Generate a new Cheque/EFT Approval report to show that all cheques that have been successfully 
printed. 

Generate an EFT Payment Batch 
If the payment will be made via EFT instead of by cheque, follow the process for adding payments to an 
EFT batch to generate a file that you will submit to your bank for processing. 

 

http://www.tronia.com/webhelp/AP/EFT_Payments.htm
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