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EFT PAYMENTS 

While you can pay your suppliers electronically via your bank’s website, agrē has the ability to 
generate an EFT payment file that can be uploaded to your bank’s website to process a payment 
batch of multiple electronic funds transfers at once. 

If you have the Grain or Shares module, you can make EFT payments to producers and 
shareholders as well as to suppliers. 

 

Related White Papers:  

Cheque/EFT Batch Payment Review Process 

Shares 

 

What you’ll find: 
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Upload the Payment Batch to Your Bank ............................................................................... 25 
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Note  Electronic Funds Transfers are limited to payments from and to 
Canadian banks only. 
 
You can make EFT payments in US dollars to a supplier's US funds 
account at a Canadian bank if your company also has a US funds 
account at a Canadian bank. As Canadian banks can process payment 
batches comprised of a single currency, each payment batch must be 
limited to either Canadian or US funds. 

http://www.tronia.com/webhelp/AP/AP_files/AP_Cheque_Batch_Review.pdf
https://www.tronia.com/webhelp/assets/docs/GL_Shares.pdf
http://www.tronia.com/webhelp/GL/GL_Files/GL_Multicurrency.pdf
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Accounts Payable - EFTs for Suppliers 

One-Time Setup Tasks 

There’s quite a few items that need to be setup (one-time tasks) before you can start generating 
EFT payment batches for suppliers, producers, or shareholders. 

Security Settings 

Note Not every user may need permission to perform all EFT tasks. For 
example, you don’t need permission to create a new AP Payment Type 
in order to make EFT payments. 

These are the security settings specific to EFT. You’ll still need permission to “regular” security 
items to setup AP reference numbers, edit suppliers, make payments, etc. 

 
File > Security > Manage Roles > Permissions >Accounts Payable 

 

 
File > Security > Manage Roles > Permissions >Accounts Payable 
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File > Security > Manage Roles > Permissions >Accounts Payable 

 
 

 
File > Security > Manage Roles > Permissions >Accounts Payable 

 
 

 
File > Security > Manage Roles > Permissions >Administration 
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File > Security > Manage Roles > Permissions >Administration 

These permissions need to be allowed only if you’ll also be using the optional Cheque/EFT Batch 
Payment Review Process. 

 
File > Security > Manage Roles > Permissions >Accounts Payable 

 

 
File > Security > Manage Roles > Permissions >Accounts Payable 

 

Help Not all users may need access to all Cheque/EFT Approval permission 
items. Please refer to the white paper on the Cheque/EFT Batch 
Payment Review Process for more details on who needs to be allowed 
to do what. 

http://www.tronia.com/webhelp/AP/AP_files/AP_Cheque_Batch_Review.pdf
http://www.tronia.com/webhelp/AP/AP_files/AP_Cheque_Batch_Review.pdf
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EFT Company Configuration Options 

Accounts Payable tab 

To be sent a copy of each supplier notification email, fill in the BCC Email Notifications field with 
the email address of who in your company should receive them. 

 
File > Config Options > Company > Accounts Payable > Payments 

Type the text that will appear in the email the supplier receives in the Email Notification Note 
field. 

Sample text for the Email Notification Note: 

An EFT Transfer has been made to your account in payment for the 
invoices listed below. Please reply to this email with any questions, 
or contact Pat Thachuk at 1.888.555.1212 ext221. 

 

If you will also be using the optional Cheque/EFT Batch Payment Review Process, you’ll need to 
check the box for that too. 

Related White Paper: Cheque/EFT Batch Payment Review Process 

http://www.tronia.com/webhelp/AP/AP_files/AP_Cheque_Batch_Review.pdf
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Reports tab 

Email Defaults 

agrē can automatically email payment notifications to your suppliers. The emails will be from 
(and thus any replies from suppliers will be sent to) the email address listed here. 

  
File > Config Options > Company > Reports tab 

 

 

The company return email address can be overwritten with a User Level Setting. 

 
File > Config Options > User > Email tab 
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Banks and Branches 

Note As long as you have the Bank Code and Branch Number, you can make 
payments to almost any Canadian bank a supplier deals with. 

 
These are the banks your suppliers bank with (a.k.a the banks you’ll be making payments to). 

 
File > Manage > EFT Bank List 

 
These are the branches your suppliers bank with (a.k.a the branches you’ll be making payments 
to). 

  
File > Manage > EFT Branch List 

 

Help Administration > Banks & Branches 

http://www.tronia.com/webhelp/Administration/EFT_Banks_and_Branches.htm
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AP Reference Numbers 

Just like cheques, agrē needs to know the next available number to assign to EFT payment 
batches. 

 
File > Manage > Reference Numbers > Accounts Payable > Company Wide tab 

Help Accounts Payable > AP Reference Numbers > Editing AP Reference 
Numbers 

 

 

AP Payment Type 

Setup a new EFT payment type. Click Settings to add your company’s banking information (a.k.a. 
the bank where the money for the EFT payments will be coming from). 

 
Accounts Payable > Manage > AP Payment Types > Add 

http://www.tronia.com/webhelp/AP/Editing_AP_Reference_Numbers.htm
http://www.tronia.com/webhelp/AP/Editing_AP_Reference_Numbers.htm
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Your bank will provide you with the details for the EFT Settings. 

 

Accounts Payable > Manage > AP Payment Types > Edit 

Note The File Path folder will be where agrē saves the payment batch file and 
must be on your local hard drive or local area network and be available 
outside of agrē. If more than one user will be making EFT payments, it 
should be on a local network drive that all users making payments will 
have access to outside of agrē. 

 

Help Accounts Payable > Supplier Payments > AP Payment Types 

 

http://www.tronia.com/webhelp/AP/AP_Payment_Types.htm
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Supplier Account: Adding EFT Details 

For each supplier that you’ll be paying by EFT, add their bank account details by clicking Manage 

EFT. After you’re done, only the branch will display. 

 
Accounts Payable > Manage > Suppliers > Edit > Settings tab 

Tip If you will (almost) always pay the supplier by EFT, you can make it the 
supplier’s Default Payment Type (which can be changed to a different type at 
the time of payment). 

The Notification Email address is the one agrē will use to send the supplier an email saying a 
payment has been made to their account. Select the Bank and Branch, and type the Account 

Number. 
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Note The supplier’s banking information is included in the EFT Payment Batch 
export file that agrē generates and that you subsequently upload to 
your bank. This is how your bank knows who you are paying, how much, 
and into which account the funds are to be transferred. 
 
If a supplier has no banking information entered, you could still pay 
them using the EFT payment type but no details of their payments could 
be added to EFT Payment Batches (agrē can’t tell your bank information 
that it doesn’t know). You would need to login to your bank’s website 
and manually provide them with the supplier’s banking information and 
payment details. 

Specific Effective Start and End dates are needed only if the supplier hasn’t started using this 
bank account yet, or is about to stop using it. No EFT payments for the supplier could be added 
to EFT Payment Batches outside of those dates. 

Help Accounts Payable > Suppliers > Adding Suppliers 

  

http://www.tronia.com/webhelp/AP/Adding_Suppliers.htm
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Grain - EFTs for Grain Producers1 

If you are not making EFT Payments to grain producers or to Shareholders, you can skip this 
section and jump ahead to Make the Payment on Page 22. 

 

One-Time Setup Tasks for Grain 

Grain EFTs are used to pay producers for settlements.  
Creating Grain EFT Payment Batches is optional.  

 

Grain EFT Security Settings 

Note Not every user may need permission to perform all Grain EFT tasks. For 
example, you don’t need permission to create a new AP Payment Type 
in order to generate an EFT payment file. 

These are the security settings specific to Grain EFT. You’ll still need permission to:  

• the “regular” security items to setup Grain reference numbers, edit producer accounts, 
etc. 

• Accounts Payable EFT Payment security permissions as needed (e.g. add new payment 
types, add banks and branches, EFT Approval, etc.) 

• and the following permissions for grain producers: 

 
File > Security > Manage Roles > Permissions > Accounts Receivable 

                                                       
 
1 When it comes to EFT payments, grain producers are equivalent to suppliers. 
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File > Security > Manage Roles > Permissions > Grain 

 

 
File > Security > Manage Roles > Permissions > Administration 

 

 

 

Grain EFT Company Configuration Options 

 

Reports tab 

Email Defaults subtab 

Setup the Email Defaults as per Page 6 (same settings as if you were making AP Payments). 
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Report Options subtab 

Check Grain EFT if you’d like agrē to Offer to Print on Save. 

 

 

 

Grain tab 

Setup the company config options for BCC Email Notifications and the Email Notification Note as per 
Page 5 (same settings as if you were making AP Payments). 

If you will also be using the optional EFT Approval Process, you’ll need to check the box for that 
too. 

Related White Paper: Cheque/EFT Batch Payment Review Process 

 
File > Config Options > Company > Grain > Purchases 

http://www.tronia.com/webhelp/AP/AP_files/AP_Cheque_Batch_Review.pdf
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Banks and Branches 

Follow the steps on Page 7 to setup the Banks and Branches your grain producers bank with (a.k.a 
the banks you’ll be making payments to). 

Grain EFT Payment Reference Numbers 

Just like cheques, agrē needs to know the next available numbers to assign to Grain payments 
(per location) … 

 
File > Manage > Reference Numbers > Grain > Location Specific tab 

… and to Grain EFT payment batches. 

 
File > Manage > Reference Numbers > Grain > Company Wide tab 

Help Grain > Manage > Grain Reference Numbers 

 

 

EFT Payment Types 

Follow the steps on Page 8 to setup a new EFT payment type for producer payments if needed.  
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Producer Account: Adding EFT Details 

For each producer that you’ll be paying by EFT, add their bank account details by clicking Manage 

EFT (similar to adding EFT info to suppliers on Page 10). 

 
Accounts Receivable > Manage > Customers > Grain tab 

The Notification Email address is the one agrē will use to send the producer an email saying a 
payment has been made to their account.  
Select the Bank and Branch, and type the Account Number. 

 

Specific Effective Start and End dates are needed only if the grain producer hasn’t started using this bank 

account yet, or is about to stop using it.  

Help Accounts Receivable > Adding Customers > Grain tab 

  

http://www.tronia.com/webhelp/AR/Adding_Customers.htm#GrainTab
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Shares - EFTs for Shareholders 

If you are not making EFT Payments to shareholders, you can skip this section and jump ahead to 
Make the Payment on Page 22. 

One-Time Setup Tasks for Shares 

Shares EFTs are used to pay dividends to shareholders.  
Creating Shares EFT Payment Batches is optional.  

Shares EFT Security Settings 

Note Not every user may need permission to perform all Shares EFT tasks. 
For example, you don’t need permission to create a new AP Payment 
Type in order to make a payment by EFT or to generate an EFT payment 
file. 

These are the security settings specific to Shares EFT. You’ll still need permission to:  

• the “regular” security items to setup Shares reference numbers, edit shareholder 
accounts, etc. 

• Accounts Payable EFT Payment security permissions as needed (e.g. add new payment 
types, add banks and branches, EFT Approval, etc.) 

• and the following permissions for shares: 

 
File > Security > Manage Roles > Permissions > General Ledger 
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File > Security > Manage Roles > Permissions > General Ledger 

 

 
File > Security > Manage Roles > Permissions > Administration 
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Shares EFT Company Configuration Options 

Reports tab 

Email Defaults subtab 

Setup the Email Defaults as per Page 6 (same settings as if you were making AP Payments). 

Report Options subtab 

Check Shares EFT if you’d like agrē to Offer to Print on Save. 

 
 

General Ledger tab 

Setup the company config options for BCC Email Notifications and the Email Notification Note as per 
Page 5 (same settings as if you were making AP Payments). 

If you will also be using the optional EFT Approval Process, you’ll need to check the box for that 
too. 

Related White Paper: Cheque/EFT Batch Payment Review Process 

 
File > Config Options > Company > Grain > Purchases 

http://www.tronia.com/webhelp/AP/AP_files/AP_Cheque_Batch_Review.pdf
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Banks and Branches 

Follow the steps on Page 7 to setup the Banks and Branches your grain producers bank with (a.k.a 
the banks you’ll be making payments to). 

 

 

Shares  EFT Payment Reference Numbers and Reference Numbers 

Just like cheques, agrē needs to know the next available numbers to assign to Shares payments 
and to Shares EFT dividend payment batches (if using optional EFT batch review process). 

 
File > Manage > Reference Numbers > Shares 

Help Grain > Manage > Grain Reference Numbers 

 

 

EFT Payment Types 

Follow the steps on Page 8 to setup a new EFT payment type for dividend payments if needed.  
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Shareholder Account: Adding EFT Details 

For each shareholder that you’ll be paying by EFT, add their bank account details by clicking 
Manage EFT (similar to adding EFT info to suppliers on Page 10). 

 
General Ledger > Shares > Manage Shareholders 

The Notification Email address is the one agrē will use to send the shareholder an email saying a 
dividend payment has been made to their account.  
Select the Bank and Branch, and type the Account Number. 

 

Specific Effective Start and End dates are needed only if the grain producer hasn’t started using this bank 

account yet, or is about to stop using it.  

Help General Ledger > Shares > Manage Shareholders 

https://www.tronia.com/webhelp/#t=GL%2FManageShareholders.htm
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Make the Payment using EFT Payment Type 

Make payments as you normally would, including from: 

• Supplier Account or Make Payments (AP > Supplier Payments > Make Payments) 

• Grain Producer Centre  

•  Shareholder Centre 

Remember to select an EFT Payment Type. 

 
Accounts Payable > Supplier Account > Pay Supplier 

Help Accounts Payable > Supplier Payments > Payments 

 

Optional:  Integration with Payment Approval Process 

If you follow the Payment Approval Process, you’ll want to add the EFT payments to an approval 
batch for review/approval before continuing. 

Help Please refer to the white paper on the Cheque/EFT Batch Payment 
Review Process for more details. 

 

  

http://www.tronia.com/webhelp/AP/Payments.htm
http://www.tronia.com/webhelp/AP/AP_files/AP_Cheque_Batch_Review.pdf
http://www.tronia.com/webhelp/AP/AP_files/AP_Cheque_Batch_Review.pdf
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Create the EFT Payment Batch 

Once you’ve made the EFT payments (paid the suppliers using an EFT payment type), it’s time to 
‘batch them up’ into an export file that your bank’s webserver can understand. 

Open the EFT Payments home form. 
By default, payment batches created in the last month are retrieved. 

 
Accounts Payable > EFT Payments – or - Grain > Grain EFT Payments 

- or - General Ledger > Shares > Dividend EFT Payments 

Add a new EFT Payment batch.  
 

Click Retrieve Payments to add EFT payments to the batch.  
The Payment Type must match the payment type used on the payments. 
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Search for payments made with the EFT payment type and indicate the date on the supplier 
payment. All locations are searched unless one (or more) is selected. 

Check Include next to the payments you want added to the EFT Batch and Save it. 

 

 

Tip Only suppliers with EFT banking details entered on their supplier account can 
be included in EFT Payment Batches. 

 

agrē creates an EFT Export file which contains the details of each payment that your bank will 
‘read’ to process the payments. 

 
The export file path is determined by the Payment Type. 
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Optionally preview the EFT Payment Batch report when prompted. 

 

Tip Before submitting the EFT Payment Batch file to your bank for processing, 

compare the Supplier Payments report to the EFT Payment Batch report to 
ensure no payments were missed (for example, if a supplier’s account 
contained no EFT info you could still pay them with an EFT Payment Type, but 
their EFT payments would have to be processed manually as they could not be 
included in an EFT Payment Batch). 

You can view the report at any time by clicking Preview Item. 

 
Accounts Payable > EFT Payments – or - Grain > Grain EFT Payments 

- or - General Ledger > Shares > Dividend EFT Payments 
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Upload the Payment Batch to Your Bank 

Follow your bank’s process for uploading the EFT file to their web server. This action triggers the 
funds to be transferred from your company’s bank account to the suppliers’ bank accounts and 
thus actually make the payments in real life. 

Rejected Batches 

If the whole batch is rejected because of a problem with a payment, the offending payment(s) 
can be removed, and the batch resubmitted to the bank. 

 
Accounts Payable > EFT Payments – or - Grain > Grain EFT Payments 

- or - General Ledger > Shares > Dividend EFT Payments 

If a payment is removed a second time, it will be deleted from the initial batch it was in (only the 
last ‘remove’ is tracked).  

After the invalid payment information is corrected, it can be added to a new batch. 

Keep track of removed payments and deleted batches with data exports. 

 
File > Export > Data 
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Confirm Payment and Send Notification Emails 

Once your bank has processed the payments, you’ll be provided with a Confirmation Number.  
Edit the EFT payment batch and enter it. 

 
Accounts Payable > EFT Payments – or - Grain > Grain EFT Payments 

- or - General Ledger > Shares > Dividend EFT Payments 

As soon as you save the payment batch, behind the scenes the Confirmation Number becomes the 
Payment Tracking Number. 

 
Accounts Payable > Supplier Payments > View Payments 

Entering a Confirmation No. and clicking Save is also what triggers the supplier notifications. 

When prompted, click Yes to send email notifications to each supplier in the payment batch. 
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The Email Notification window displays how many emails were sent. 

 

Tip This value should match the number of suppliers in the payment batch. If it 
doesn't, you may have forgotten to enter an EFT Notification Email Address 
on a supplier's account. 

Note If no From email address is setup (either at the Company or User level) 
agrē will not send any notifications. Enter a valid return address, edit 
the EFT payment batch again, and save. You will be prompted to send 
the notifications. 

 

Your supplier will receive an email notifying them that you have made an EFT Payment to their 
account. 

 

../Configuration/company_level.htm#RptEmailAddress
../Configuration/User_Level.htm#user_email
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Optionally preview the EFT Payment Batch report when prompted. The Confirmation Number and 
email Notification Date are now shown. 

 

 

Note: If you have any questions or require further assistance with EFT 
Payments, please contact your CSC at support@tronia.com.  

 

 

mailto:support@tronia.com

