
   

Last Updated: 2023.10.03 

AR CREDIT LIMITS 

agrē is very flexible when dealing with customers with credit limits and cash customers. You get 
to decide what your company defaults are for handling cash customers and for credit 
customers who have reached their limit. You can set different behaviours for different 
customers and you can allow certain agrē users to override the defaults. 
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What is a Credit Limit? 

The customer credit limit is the highest dollar amount the customer is allowed to owe you. 

 

Is a Credit Limit the same as a Line of Credit? 

No, Lines of Credit recorded in the Banking Information section of the Customer Account are 
FYI only. They are not included in any credit limit calculations. 

 

How Does agrē Decide How Much a Customer Owes 

You? 

agrē doesn’t decide – you do! agrē calculates how much a customer owes you based on the Company 

Level Credit Config Options that you select. If a customer has prepayment money left, you get to decide 

if this amount is part of the customer’s balance or not. 
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Credit Limit Behaviours 

What are Credit Limit Behaviours? 

Credit Limit Behaviours determine how agrē checks a customer’s credit limit, and what it should 
do when a customer reaches his credit limit. agrē needs to know if you want to include the 
customer’s prepayment funds as part of their credit limit, and if it should be including unbilled 
loadout tickets as part of the customer’s account balance. When a customer reaches their limit, 
agrē needs to know if it should come to a dead stop until the customer makes a payment, or if 
it should provide just a warning. 

1. When checking credit limits, use chargeable balance (i.e. exclude prepayment credits 
from consideration) 

•  This will use the customer’s regular Chargeable Balance instead of the Net Balance 
whenever checking to see if they are over their credit limit – basically, having 
prepayment dollars on account won’t increase their available credit. 

2. Prevent LOTs when customer is at or over credit limit (unless all purchases on the LOT 
are linked to a prepaid work order line) 

•  “on” is a dead stop for LOTs when the customer is at or over  

•  “off” is a warning only 

3. Force immediate payment on save of invoice when customer is at or over limit. 

•  “on” will require an immediate payment of the entire amount of the balance that 
is over the credit limit (otherwise you won’t be able to save the invoice) 

•  “off” is a warning only 

4. Prevent adjustments that increase customer balance when already over credit limit 

•  “on” will prevent you from making adjustments to increase the chargeable 
balance 

•  “off” will allow it, but with a warning 

5. When warning about a customer approaching/at their credit limit, include the estimated 
value of unbilled LOTs when determining current charges  

Note: this behaviour does not affect ' full stops', only warnings 

•  “on” will add up the estimated value of unbilled LOTs when determining whether 
or not to warn of approaching limit 

•  “off” will use just the actual current outstanding balance 
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Where are Credit Limits set? 

Usually you have some general company-wide policies that apply to most customers. You 
would set these as defaults at the Company level. Then there are the exceptions. Each location 
can have its own credit limit behavior defaults, but not its own credit limit and range. For 
customers that need something different from the company or location defaults, make changes 
to their account at the Customer level. Each customer can have a different limit, range, and 
behaviours. You can also allow agrē users to override the default credit behaviour settings. 

Company Level Credit Config Options 

Set your Company defaults to what will be applicable to most customers. The default Limit and Range 

determine what a new customer receives as starting settings on the Manage Customers > Credit Info tab. 

You can always change an individual customer’s credit limit and credit behaviors if theirs should be 

different from the defaults. 
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Location Level Credit Config Options 

At the Location level, you can specify different credit limit default behaviors regarding the 
saving of LOTs and Invoices. These will override the Company defaults only for the locations you 
specify. You cannot specify different ranges and limits for just one location, but you could do 
that for the individual customers at that location.  

To specify Location specific credit limit behaviours, set them under File > Config Options > Locations. 
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Customer Level Credit Info Tab 

The Customer level credit settings offer more flexibility than the location behaviors. These 
options work the same as those for the Company, but will override those of both the Location 
and the Company. 

 

1. Make customer specific exceptions in the Customer Account. 
•  For each customer you can set a credit limit, credit range and interest rate. If you 

decide to specify a Credit Limit, it must be a positive number or zero. 

Note For Cash Customers there are business rules associated with the option 
Allow prepayment deposits and prepaid work orders. If the customer has 
existing prepaid work order detail rows and/or a current prepayment 
balance, you will not be allowed to save your changes if the second 
option is unchecked. 

•  “For LOTs and Invoices, treat this limit as” is a drop down list (warning only, full 
stop, follow defaults). Selecting “warning only” elicits a warning the customer has 
reached or exceeded their limit. Selecting “full stop” is a dead stop – you will not 
be allowed to continue the transaction that would push the customer over their 
credit limit (e.g. saving the LOT or invoice). 

•  Interest rate must be a positive number between 1 and 100.  
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•  When Save is clicked agrē checks if the interest rate has changed. If so, you’ll be 
asked if the change of interest rates should also be applied to outstanding items, 
or used on a go-forward basis only. 

2. When asked about changing interest rates on existing invoices, click Yes or No.  

•  “Yes” will change the chargeable interest rate on all existing outstanding Invoices, 
Adjustments, and Interest Items. 

•  “ No” will leave the rate on those items as they are, but the new rate will be 
applicable to any new ones created from now on. 

 

Note: When you’re asked if you’d like to apply the new rate to “all existing 
outstanding items” and you click “yes”, agrē will apply the new rate to 
every item that you see when you click the Manage Outstanding Items 
button. It will not go back and recalculate any interest that has already 
been charged. 
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Example Customer Settings 

You’re really dealing with two kinds of customers:  

• credit customers (customer allowed to carry a balance) 

• cash customers (customers who aren’t) 

A customer with a $0 credit limit is not the same as a cash customer.  

Caution  Product returns from Credit customers with a $0 credit limit are handled 
differently than returns from Cash customers. 

Settings for Credit Customers 

Customer accounts with a specified credit limit can carry up to their allowable chargeable bal-

ance. You get to decide what happens when they hit that amount – do you want just a warning 

(you know they’re good for it), or do you want to come to a full stop (prevent them from taking 

more)? When Credit customers return product, you have the option of flagging it as prepaid. If 

flagged as prepaid, the funds will be added to their remaining prepay amount. If not flagged as 

prepaid, the funds become an unapplied credit. You could also return their funds, but agrē 

won’t force you to. 

 

Note:  You probably don’t need to classify any customers with a $0 credit 
limit. You’d likely turn them into a cash customer of one form or 
another. 
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Tip When creating an invoice, click View Credit to quickly view a customer’s Credit 
Limit 

  

 

Settings for Cash Customers 

There are two types of cash customers:  

• those you know 

• those you don’t 
 

Counter Sales (cash customers you don’t know) 

These are the classic “cash customers” that walk in off the street. You might not know their names, and 

maybe you never will. You may have one account per location that you use to record counter sales [like 

“Cash Sales (Kelowna)”]. These customers are going to have to pay every time for what they take. If they 

return product, you’ll need to give them a refund (accept an immediate payment for a negative dollar 

amount), because these accounts cannot carry a credit chargeable balance. 
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“Credit-less Customers” (cash customers you know) 

These are customers that have an account in their own name; they just don’t happen to have 

any credit with you. They likely have their own account because they setup prepayment plans, 

but you’re not letting them carry a chargeable balance over and above their remaining prepay-

ment funds. If they return product, you would need to flag it as prepaid or return the funds (ac-

cept an immediate payment for a negative dollar amount) because the account cannot carry a 

credit balance. 
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Batch Update of Customer Credit Limit Details 

If you frequently change customer credit limit details, or you’re setting up specialized customer 
credit details for the first time, it’s much easier to update them all at once but you’ll need 
security access to the batch update form first. As with all new features, we don’t presume to 
know who should have access to it and who should not, so we leave that up to your local 
company security administrator. 

Batch Updates of Customer Credit Limits 

1. Start the batch update process from Accounts Receivable > Manage > Customer Credit & 

Interest Settings. A search form opens up so you can select which customer(s) should be 
edited. Choose all your customers, or a choose subset by location or characteristic. 

2. Set the details for each customer and Save. 
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Can I Override the Default Credit Behaviours? 

You sure can! You can allow agrē users to override the location or company default settings or 
specific customer settings. You could decide that only the Counter Sales Supervisor will be 
allowed make the decision to override the defaults and save an invoice or LOT even if it would 
push the customer over their credit limit. The override users would still receive the same 
warnings that the customer was close to, or over, their credit limit as other agrē users would 
receive. 

Caution  User Config Options override all Company, Location, or Customer settings! If 
you don’t want to allow your users to change these settings themselves, you 
may need to change your security setup. 

For agrē users who are allowed to override default settings, change their User Config Options. 
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Security for Credit Limits 

Note: Security settings are managed by your local company security 
administrators. With new features, we don’t presume to know who 
should have access and who should not, so we leave that up to them. 

To allow, or to not allow, users to change (or even see) Customer credit limit details and interest rates, set 

the Edit Credit Limit and Edit Interest Rate flags on the Accounts Receivable tab accordingly in File > 

Security > Manage Roles. 

 

To allow, or to not allow, users to change to override Company or Location credit limit behaviours, set 

the Config Options User > Enable on Menu  and > Manage flags on the Administration tab accordingly 

in File > Security > Manage Roles. 

 



 

AR Credit Limits  Page 14 of 14 

Grant permission to the batch Customer Credit & Interest Settings form under File > Security > Manage 

Roles by checking the Allow checkbox next to the corresponding item. 

 


