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POINT OF SALE/POS INVOICE SETUP 

A POS Invoice is an abbreviated version of the regular agrē invoice that’s designed for speed! You 
can use a barcode scanner to quickly enter items onto the invoice, take the customer’s payment, 
and print the till-tape receipt. Even without a barcode scanner you’ll be able to enter a POS 
Invoice quickly using special keyboard shortcuts.  

POS Invoices are much faster to enter but the trade-off is less 
flexibility - you aren’t able to add blends, or indicate a shipping 
address, there’s no place for flagging purchases as prepaid or 
selecting a Lot Number (Lot#), you can’t link to or import from a 
loadout ticket or work order, and some payment types may not be 
acceptable.  

POS Invoices are formatted to print on “till-tape” instead of on an 8½ 
x 11 sheet of paper (but there is a way to print them like regular invoices on the fly if you need 
to). 

What you’ll find: 

Setup (one-time tasks) .............................................................................................................. 2 

Installing the Hardware ......................................................................................................... 2 

Bar Code Scanner .............................................................................................................. 2 

Receipt Printer Installation ............................................................................................... 2 

Security Permissions ............................................................................................................. 6 

Configuration Options ........................................................................................................... 7 

Printers .............................................................................................................................. 7 

Font Size ............................................................................................................................ 8 

AR Return Process (optional) .......................................................................................... 10 

Associated Product Behavior for Scanned Items (optional) ........................................... 11 

Location Settings ................................................................................................................. 12 

AR Payment Types ............................................................................................................... 13 

Products............................................................................................................................... 13 

UPC Codes ....................................................................................................................... 14 

Tax-Included/Gross-Unit Pricing (optional) .................................................................... 15 

Emailing Customer Receipt (optional) ................................................................................ 16 

Toolbar Customization (optional) ....................................................................................... 16 

Appendix I - Cash Drawer Codes ............................................................................................. 17 



Point Of Sale/POS Invoice Setup  Page 2 of 22 

Setup (one-time tasks) 

Installing the Hardware 

Bar Code Scanner 

Before you open up agrē, you’ll need to have the barcode scanner connected to your computer 
with the latest drivers installed. 

Receipt Printer Installation 

While you can use most thermal printers to print the receipts, the POS Invoice Cash Drawer 
functionality is compatible only with the following Epson Thermal Line receipt printers: 

• TM-T20 • TM-T20II • TM-T20II-m • TM-T70 

• TM-T70II • TM-T81II • TM-T82 • TM-T82II 

• TM-T88V • TM-T90II • TM-P20 • TM-P60 

• TM-P60II • TM-P80 • TM-U220 • TM-U330 

• TM-m10 • TM-m30   

The printer driver must be installed before Citrix is opened as all drivers are loaded on launch. 
The driver should be supplied with the receipt printer itself, but if not Epson drivers can be 
downloaded from the following webpage: 

https://c4b.epson-biz.com/modules/pos/index.php?page=soft&scat=31 

The screenshots here are for the Epson TM-88V, but the setup process is similar for most 
thermal printers.  

Accessing the printer settings after the 
installation of the driver requires the printer 
to then be registered using an application that 
was installed with the driver software.  
 
If not prompted to register at the end of the 
driver installation, it can be accessed from the 
Windows Start Menu in the Epson Advanced 
Printer Driver folder.  
Click on EPSON APD5 - Register, change, or 
delete TM Printer. 

 

https://c4b.epson-biz.com/modules/pos/index.php?page=soft&scat=31
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The Register, Change and Delete Printer window opens.  
Select the printer model and port type, then Save Settings. 

 

After Save Settings is complete, you’ll be 
prompted to perform a test print – click Yes. 

 

 

After test print is successful Close the window. 

 

Next up is setting the printing preferences for 
the Thermal Line printer to enable some 
additional options.  

 

Navigate to your Control Panel in Windows … 
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… and select Devices & Printers.  

 

 

 

Right-click on the receipt printer 
and select Printing preferences. 

 

 

 

The Receipt Printing Preferences 
window should look very similar to 
this one (depending on your model 
of printer).  

 

Select the Feed and Cut tab. 
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Select Document [Feed, Cut] . 

Select the End of Document sub-
tab. 

Check the box to Feed to cut 
position before cutting.   

Set the Cutting method to Cut. 

 

These settings ensure the printer 
will cut the receipt after all lines 
have been printed.  

 

 

 

Select the Peripherals tab. 

 

 

 

Select Cash Drawer from the drop-
down list. 

Leave the Start of Document sub-
tab selected. 

Set Cash Drawer #1 and 
Cash Drawer #2 to Do not open. 

 
agrē will send the instructions to 
the printer to have the cash drawer 
open, so you won’t want Windows 
to open it a second time. 
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Select Cash Drawer & Built-in 
Buzzer from the drop-down list. 

Leave the Start of Document sub-
tab selected. 

Set Cash Drawer #1 to Do not 
open. 

Set Built-in Buzzer to Turn off. 

 
agrē will send the instructions to 
the printer to have the cash drawer 
open and play a sound, so you 
won’t want Windows to open it 
and chime a second time. 

 

 

Click OK to save the printing 
preferences and to close the 
window. 

 

 

 

Now that the printer is installed, registered, and setup you can start agrē. 

 

 

Security Permissions 

Before you can setup and use POS Invoices in agrē you’ll need permission. 

 

File > Security > Manage Roles 

Allow POS Cash Drawer permission only if the user should be allowed to open the cash drawer 
manually at any time (if not checked, the cash drawer will still open when accepting a payment 
type that needs it to open – the user just can’t open the cash drawer at will). 
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Configuration Options 

There are a few POS Invoice configuration options that can be set at the company level, or at the 
user level (which, as usual, will override the company defaults). 

Printers 

Now that agrē will be working with two printers, it needs to know which one you’ll use for 
printing POS Invoices on till-tape and which one you’ll use for printing Standard Reports (the 8½ x 
11 ones like regular invoices, customer sales, inventory balances, etc.). This can be done at the 
company level, or at the user level (which, as usual, will override the company defaults). 

Note When Quick Print POS is checked, POS Invoices will be sent directly to the 
receipt printer – they will NOT display on screen before printing. 

Company Level 

 

File > Config Options > Company > Reports tab 

See Appendix I for Cash Drawer Codes for compatible printers. 

Note Check Omit Cash Drawer if a) you are not using a cash drawer, or b) your POS 
receipt printer is not compatible (as it is the printer that sends the instructions 
to the cash drawer to open). 
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User Level 

 

 
You may also want to set a Default Location for users so 

agrē will fill that in for them on each POS Invoice 

File > Config Options > User 

 

 

 

Font Size 

Select POS Invoice: Large Fonts if you’d like the fonts to display a little larger. 
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AR Return Process (optional) 

The AR Return Process restricts the returning of items without a receipt (for example, when a 
customer brings back a drum or tote purchased elsewhere for return of their deposit) to 
specified users. If you want to enforce it, check Require Security to Return without a Receipt. 

 

File > Config Options > Company > Accounts Receivable tab 

 

 

Grant permission to Return without Receipt to those users who will need it. 

 

File > Security > Manage Roles 
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Associated Product Behavior for Scanned Items (optional) 

If using a scanner to add items, the default Quantity is always 1. If the scanned item has optional 
Associated Products, the default Quantity of those is also 1. If you were adding more than 1 of the 
scanned item, you’d need to either scan the item and select the optional Associated Product(s) 
multiple times or you’d need to edit each product row and update the quantity.  

When POS Invoice: Scan with Non-Mandatory Associated Product: Edit Qty is checked, after scanning 
an item with optional associated products agrē pops up the regular Add Product window to allow 
you to change the Quantity of the scanned item before the Associated Products are added - so 
there is no need to scan the item multiple times, or go back and edit each row. 

 

File > Config Options > Company > Accounts Receivable tab 
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Location Settings 

Optionally add a POS Invoice note to display on each POS Invoice receipt. 

 

File > Manage > Locations 

Each location may have a different note, and the note can be updated at any time. 
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AR Payment Types 

Only AR Payment Types with Show on POS Invoice checked will be available when accepting 
payment for POS Invoices. For example you may want to allow POS payments of cash, debit, and 
credit cards, but not FCC or cheques. 

 

Accounts Receivable > Manage > AR Payment Types 

You also have the option to print a second Merchant Copy of the invoice and payment receipt, 
for all POS Invoices or just those over a certain dollar value, with or without a Signature Line for 
the customer to sign.  

• Merchant copies are available only when printing POS Invoices.  

• If you’re printing a Full Invoice you will not get a merchant copy.  

• If you are returning items on a POS Invoice you will get a merchant copy whether this box 
is checked or not - returns always require a customer signature! 
 
 

Products 

Note Products flagged as requiring a Lot# must be saved on a full invoice. 
 

 
  Inventory > Manage > Products / Lot Number Required? 
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UPC Codes 

If you’ll be using a scanner, setup UPC codes for items. 

 

Inventory > Manage > Products 

 

Items with multiple Unit Types can have corresponding UPC codes for each unit. 

For example, you sell cola by the can (Eaches) and by the Case of 12 cans.  
UPCs 1-5 are associated to a can (the main/mapped unit type).  
UPCs 6-7 are associated to a case. 
When scanning the item, the unit type and price will default to match the UPC scanned.  
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 Tax-Included/Gross-Unit Pricing (optional) 

Note There is a config option Tronia must turn on in the background to enable 
gross-unit (or tax-included) pricing. 

To sell items like fuel on POS Invoices, where the posted price includes the taxes, you’ll need to 
tell agrē that the price you’re setting does in fact include the taxes. 

 

Inventory > Manage > Products 

 

 

After you’ve set the price to include the taxes, when you add the item to a POS invoice (or a 
regular invoice) agrē will reverse-engineer the gross-unit price to calculate the usual unit price 
and the taxes. 
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Emailing Customer Receipt (optional) 

Note POS Invoice Receipts can be emailed without adding an address to the 
customer account by entering one on the fly. 

If you will be emailing customers a copy of their POS Invoice Receipt, adding an email address to 
the customer accounts in advance will save you the time of having to enter one manually for 
each POS Invoice. 

 

Inventory > Manage > Products 

This address can be changed at the time of emailing the POS Invoice. 

 

 

Toolbar Customization (optional) 

For users creating Point of Sale invoices 
on a regular basis, consider having them 
add the POS Invoice quick button to their 
tool bar. 

 

 
 

 
Window > Customize Toolbar 
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Appendix I - Cash Drawer Codes 

Manufacturer Model Drawer Codes Cutter Codes 

3NSTAR LPT005 27,112,0,25,250 . 

AGPTek SC9-5870 27,112,0,25,250 . 

Appostar RTP-3280 27,112,0,25,250 . 

Axiohm A715 27,112,0,48,251 27,105 - Full 

 A756 OR 27,109 - Partial 

 A794 27,112,1,49,251  
Bematech MP-250TH 27118140 . 

Bematech SRP-350PLUSiii 27,112,0,50,250 . 

Bixolon SRP-150UG 27,112,0,50,250 . 

Bixolon SRP-275 27,112,48,55,121 . 

Bixolon SRP-280 27,112,0,64,240 . 

Bixolon SRP-330 27,112,0,25,255 . 

Bixolon SRP-350 27,112,0,50,250 . 

 SRP-350ii   

Bixolon SRP-375P 27,112,48,55,121 . 

Code Soft 3200 SERIES 27,112,0,25,250 . 

Code Soft DP7645III 27,112,48,55,121 . 

Custom Q3 27,112,0,50,250 27105 

Dell T200 7 . 

DCAPOS POS 8350 27,112,0,25,250 27105 

DIGIPOS DS-800 27,112,48,55,121 . 

EC-Line EC-PM-520 27,112,0,40,168 . 

 EC-PM-80330   

EC-Line EC-PM-5890X 7 . 

Epson ? 27,112,48,55,121 . 

Epson TM-T20 27,112,48,55,121 . 

Epson M51PD 27,112,0,25,250 . 

Epson TM-T60 27,112,32,25 . 

Epson TM-L60II 27,70,0,50,50 . 

Epson TM-T70 27,112,48,55,121 27109 

Epson TM-T80P 27,112,0,25,250 . 

Epson TM-T81 27,112,0,25,250 27109 

Epson TM-82 27,112,0,25,251 . 

 TM-82ii   

Epson TM-T85 27,112,0,25,250 . 

Epson TM-T88 27,112,0,25,250 27109 

Epson TM-T88II 27,112,0,25,250 27121 

Epson TM-T88IIP 27,112,48,55,121 27109 

Epson T88iii 27,112,0,25,250 27109 

Epson T88iiiP 27,112,0,64,240 27109 
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Epson TM-88IV 27,112,48,55,121 27, 109 

Epson TM-88V 27,112,48,55,121 . 

Epson TM-90 27,112,0,25,250 27109 

Epson M115A 27,112,0,25,250 . 

Epson M129C 27,112,0,64,240 27109 

Epson M188A 27,112,0,25,250 . 

Epson M188B 27,112,48,55,121 27,112,0, 5,250 

 M188D   

Epson M192C 27,112,0,64,240 27109 

Epson M192H 27,112,0,64,240 27109 

Epson T200 27,112,0,25,250 . 

Epson TM-200 27,112,0,64,240 . 

Epson TM-200 27,112,0,25,250 27,112,0,75,250 

Epson TM-U200B 27,112,48,25,250 . 

Epson TM-U200D 27,112,0,64,240 . 

Epson TM-U210PD 27,112,0,25,250 27,112,0,75,250 

 TM-U210D   

Epson TM-220 27,112,0,25,250 . 

  OR  

  27,112,0,64,240  
Epson TM-U220 27,112,0,25,250 . 

  OR  

  27,112,0,64,240  
Epson TM-U220A 27,112,0,25,250 27,112,0,75,250 

 TM-U220PD OR OR 

  27112 27105 

Epson TM-U220B 27,112,0,25,250 . 

 TM-U220PD   

Epson TM-U220D 27,112,0,25,250 27,112,0,75,250 

 TM-U220PD   

Epson M253A 27,112,48,55,121 . 

Epson TM-U295 27,112,48,55,121 . 

Epson ADP 300 27,112,0,25,250 . 

Epson TM-300D 27,112,0,25,250 27105 

Epson LX-300+ 27,112,0,25,250 . 

  OR  

  27,112,48,55,121  
Epson TM-U300PC 27,112,0,25,250 . 

 TM-U300PD   

Epson TM-U325D 27,112,0,25,250 . 

Epson TM-U375 27,112,0,25,250 . 

Epson ECP-500 27,112,48,55,121 . 

Epson M665A 27,112,48,55,121 . 
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Epson TM-T883P 27,112,0,50,250 27109 

Epson TM-U950P 27,112,0,50,250 . 

Epson TM-H5000II 27,113,0,25,250 . 

  OR  

  27,25,247  
Epson TM-H6000 27,112,48,55,121 . 

 TM-H6000ii   

Epson TM-J7100 27,112,48,55,121 27109 

Essae PR-85 27,112,0,100,100 . 

Gainscha GP-80160 27,112,0,100,250 . 

Goangzhou AB-88A 27,112,0,50,250 . 

Gprinter GP-5890 27,112,0,100,250 . 

 GP-80160   

Fujitsu fp-350 27,112,0,48,251 . 

Fujitsu fp-410 27,112,1,49,251 . 

HP A798 27,112,0,8,8 . 

 A799   

 A799-C40W   

HPRT TP805 27,112,0,250,250 . 

IBM 4610 7 . 

IBM 4610 27,112,0,50,250 27,12 

IBM Sure POS 27,112,0,250,250 . 

IDIPOS AB-88H 27,112,0,50,250 . 

INFOCOMM P80 27,112,0,50,250 . 

Ithaca PcOS 50 27,112,0,25,250 . 

  or  

  7  
Ithaca PcOS 51 27,112,0,25,250 . 

  or  

  7  
Ithaca PcOS 52 27,112,0,25,250 . 

  or  

  7  
Ithaca POSjet 27,112,0,25,250 . 

Ithaca 80 PLUS 27,120,1 27118 

Ithaca SERIES 90 27,120,1 . 

Ithaca SERIES 94 27,120,1 . 

Ithaca 150 27,120,1 . 

Ithaca 280 27,112,0,250,250 27105 

  27,112,1,49,251 27109 

Ithaca iTherm 280 27,120,1 27118 

  27,120,2  
Ithaca POSjet 1000 27,120,1 . 
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  27,112,0,25,250  
Jolimark TP820 27,112,0,100,250 . 

Kasir Enibit P58B 27,112,0,25,250 . 

Koohii SMART 300 27,112,0,25,250 . 

MetaPace T1 27,112,48,55,121 . 

 T3   

NCR 7167 Drawer #1 27, 105 

 7179 27,112,0,55  

 7197 Drawer #2 27, 109 

  27,112,1,55  
NCR 7223 27,112,80,25,250 27, 112,1,55 

NEC TSP-100 7 27100 

NEXA PX700 27,112,0,50,250 . 

Obvios ORP-800 27,112,0,25,250 . 

Ojuled POS58 27,112,0,25,125 . 

Oki OKIPOS 407 7 27,100,49 

Oki OKIPOS 1000 27,120,1 27118 

Olivetti PRT-100 27,112,0,25,250 27,12,0,25,250 

POS-X PT3 27,112,0,25 . 

POS-X XR-200 27,112,0,25,250 27105 

 XR-250   

 XR-500   

POS-X EVO-RP1 27,112,0,25 27105 

Posiflex CR 4200 27,112,80,25,250 . 

  OR  

  27,112,0,25,250  
Posiflex AURA 5600 27,112,0,25,250 . 

 AURA 8000 or  

  27,112,80,25,250  
Posiflex PP6000 27,112,0,25,250 . 

 PP6900   

 PP7000   

 PP8000   

Samsung STP 131 27,112,0,48,50 . 

Samsung SRP 220 27,112,48,55,121 . 

Samsung SRP 270 27,112,0,25,250 . 

  OR  

  27,112,0,60,240  
Samsung SRP 270A 27,112,0,64,240 . 

Samsung SRP 275 27,112,48,55,121 . 

 SRP-275AP   

 SRP-275C   

Samsung SRP 350 27,110,0,25,250 . 
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Samsung SRP 350T 27,112,0,50,250 . 

Seiko ESC-POS Drawer #1 Full cut 

 RP-B10 27,112,0,50,250 27, 105 

 RP-E10 Drawer #2 Part cut 

  27,112,1,50,250 27, 109 

Sensonic T-300 27,112,0,25,250 . 

Sewoo LK-TL-322 27,112,0,50,250 . 

Shenzhen POS-8350 27,112,0,25,250 . 

Sinocan PO6-U/S/L 27,112,48,55,121 . 

SNBC BTP-M280 27,112,0,50,250 . 

SNBC BTP-R880NP 27,112,48,55,121 . 

SNBC BTP-2002NP 27,112,48,40,200 27105 

Star All? 27,7,11,55,7 . 

Star TSP 100 7 27100 

 TSP 100ii   

Star TSP 100IIU 27,7,11,55,7 27,100,48 

Star SP200 27,7,11,55,7 . 

 SP200-2   

 SP212   

Star TSP200 27,7,11,55,7 27,100,48 

Star SP500 27,122,49,7 27,100,48 

  OR  

  27,7,11,55,7  
Star SP512 27,122,49,7 27,100,48 

Star SP550II 27,7,10,50,7 . 

Star TSP-600 7 27,100,51 

  OR  

  27,7,10,50,7  
Star TSP-613TSP-650TSP-654iic 7 . 

  27,7,10,50,7  

  27,7,11,55,7  
Star TSP-700TSP-700ii 27,07,11,55,07 27,100,51 

Star TSP-743ii 27,7,11,55,7 27,100,51 

Star SP2000 27,122,49,7 27,100,48 

Star Micronics TSP-650 27,112,0,48 . 

Star Micronics dp-8340fm 27,7,11,55,7 . 

Syncotek SP-POS88VI 27,112,48,32,64 27109 

TEC RKP300 27,112,0,100,250 27105 

TEC TRST-A10 27,112,48,55,121 . 

TEC TRST-53 27,112,0,100,250 27105 

 TRST-56   

Toshiba TRST-A10 27,112,48,55,121 . 

 TRST-A15   
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Toshiba SUREPOS500 27,112,0,250,250 . 

Toshiba SX2100 27,112,32,55,255 . 

TOSHIBA TEC DRJST-51 27,112,0,100,250 27105 

TPG A776 27,112,1,49,251 . 

 A794   

 A798   

TVS RP-3200 27,112,0,100,250 . 

TPG A799 27,112,0,8,8 . 

Tysso PRP076 27,112,0,50,250 . 

 PRP300   

UCOM U808 27,112,0,25,25 . 

Unisys EF4272 27,112,0,100,250 . 

WASP F100 27,112,49,48,48 27105 

 WTP-100   

WESTREX 4200 7 20 

Xprinter XP-C20-K 27,112,0,148,49 . 

 XP-360   

 XP-350-B   

Zjiang POS-58 27,112,0,150,250 . 

Zjiang ZJ-8200 27,112,0,48,48 . 

Zjiang ZJ-8250 27,112,0,25,250 27,105 Full 

   27,109 Partial 

Zonerich AB-88H 27,112,0,50,250 . 

 


