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SHARES 

 

Shares allows you to track Shareholders and issue Certificates, Transfer and Buyback shares, 
declare Dividends, and make Dividend Payments. 

 

Related White Papers 

EFT Payments 

Cheque/EFT Batch Review Process 
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Shares Setup 

Security Permissions 

Before you can start setting up Shares, you’ll need permission to manage them. 
Not every user will need permission to do all tasks, but at least one user should have permission 
to do everything. 

 

File > Security > Manage Roles 
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General Ledger Accounts 

At least 2 general ledger accounts are required for Shares: 
 

1. Retained Earnings  
(can be the company Retained Earnings account, or a separate Retained Earnings account 
just for Shares, or a separate account for each Share Class - check with your accountant 
for their preferred method). 
 

2. Dividends Payable 

 

General Ledger > Manage > Chart of Accounts 

Tip The data export for Chart of Accounts shows you the account setup in an easy-
to-compare format. 
  
Got to File > Exports > Data, click on the + sign next to General Ledger to 
expand, click Chart of Accounts, then click Preview Data. 

Help For details on how to set up the GL Accounts, please refer to the General 
Ledger chapter of online Help.  

http://www.tronia.com/webhelp/GL/GL_Chart_of_Accounts.htm
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Company Config Options 

Automatically generate Transaction Number must remained checked, and a Dividend GL Account 
number must be entered (this will be the Dividend Payables account created above in General 
Ledger Accounts).  

Leave the other options to automatically generate reference numbers checked, or you can enter 
your own unique reference number manually for each action as needed. 

 

File > Config Options > Company 

Help For details on how to work with Configuration Options, please refer to the 
Configuration Settings chapter of online Help. 

http://www.tronia.com/webhelp/Configuration/Configuration_Settings.htm#Configuration_Settings
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Reference Numbers 

Now that agrē knows it’s going to automatically assign Reference Numbers, it needs to know 
which number(s) to start with. 

 

File > Manage > Reference Numbers > Shares 

Note Prefixes are optional and can be up to 5 characters.  
Starting Numbers can be up to 10 characters.  

If you do not want agrē to automatically generate reference numbers for certain actions, leave 
the boxes blank and you will be prompted to enter a unique reference number manually on save. 

Manage Share Classes 

A Share Class is a designation applied to a specified type of Share. If you have more than one 
class, they are usually identified with alphabetic markers (e.g. "Class A" shares and "Class B" 
shares). 

 

General Ledger > Shares > Manage Share Classes 

The unique Share Code (5 character max) cannot contain spaces, but the Description (50 char max) 
can. 
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Manage Shareholders 

Shareholders can be of various types (e.g. Individual, Joint, Company, Trust, etc.) and own one or 
multiple share certificates (decimal values controlled by config option). The attributes are used 
when generating dividend payments, for income taxes (T5), and to report to CRA. 

 

General Ledger > Shares > Manage Shareholders 

If you are entering the Shareholder No manually, it must be unique, numeric (9 digit max) with no 
spaces, leading zeros are allowed.  

The Recipient ID No is usually the shareholder’s Social  
Insurance Number (SIN). 

Shareholders cannot be deactivated if they have certificates. 
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Shares Activities and Transactions 

Shareholder Centre 

The Shareholder Centre has one tab for shares Activity … 

 

General Ledger > Shares > Shareholder Centre 

… and one for shares Certificates. 

 

Until a Shareholder has some Shares Transactions or Certificates, these tabs will be empty. 
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Share Certificates 

Shares Certificates can be added from the Shareholder Centre or from the Share Certificates window. 

 

General Ledger > Shares > Shareholder Centre  
 - or - 

General Ledger > Shares > Share Certificates 

 

If you are entering the Certificate No manually, it must be alphanumeric (15 char max) with no 
spaces, leading zeros are allowed. 

Share Certificates cannot be edited - if a mistake is made the certificate must be deleted and 
recreated. 
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All Issued shares are shown by default. Cancelled certificates can be displayed by selecting Show 

All. 

 

General Ledger > Shares > Shareholder Centre 

 

 

Creating a Share Certificate adds a new Shares Transaction with the Type of Issue. 

 

General Ledger > Shares > Share Transactions 
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Share Certificates can be printed from the Shareholder Centre or the Shares Certificates window. 

 

 
The Shareholder Summary report lists all shares by Certificate number. 

 

General Ledger > Shares > Reports 

 

sorted by Class and Date Issued 
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Share Transfers 

Share Transfers can be added from the Shareholder Centre or from the Share Transactions window. 

 

General Ledger > Shares > Shareholder Centre  
 - or - 

General Ledger > Shares > Share Certificates 

Shares are Transferred when the ownership of shares is transferred/sold from one share certificate 
to another share certificate. 

 

If you are entering the Reference No manually, it must be alphanumeric (15 char max) with no 
spaces, leading zeros are allowed. 

The Transaction Date can be backdated (but not before the Share Certificate was issued) but 
cannot be in the future. 

If you are entering a Certificate No manually, it must be alphanumeric (15 char max) with no 
spaces, leading zeros are allowed. 
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The Transfer is displayed on the Share Transaction window, and on the Shareholder Centre. 
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Share Buybacks 

Share Buybacks can be added from the Shareholder Centre or from the Share Transactions window. 

 

General Ledger > Shares > Shareholder Centre  
 - or - 

General Ledger > Shares > Share Certificates 

A Buyback is when you pay a Shareholder for their shares. 

 

If you are entering the Reference No manually, it must be alphanumeric (15 char max) with no 
spaces, leading zeros are allowed. 

The Transaction Date can be backdated (but not before the Share Certificate was issued) but 
cannot be in the future. 

If you are entering a Certificate No manually, it must be alphanumeric (15 char max) with no 
spaces, leading zeros are allowed. 
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The Buyback is displayed on the Share Transaction window, and on the Shareholder Centre. 
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Dividends 

Dividends are added from the Dividends window. As dividends are not calculated often, all prior 
dividends are displayed (no need to search). 

 

General Ledger > Shares > Dividends 

Dividends can be calculated for all share classes (if the rate is the same for all leave the Class field 
blank), or for just one share Class, and can be calculated by $ per share or by % of Issued Value. 

 

General Ledger > Shares > Dividends > Add 

If you are entering the Reference No manually, it must be alphanumeric (15 char max) with no 
spaces, leading zeros are allowed. 

The Declaration Date is the posting date (cannot be in the future). 

The Record Date is the “as of” date for which the number of shares/share value are calculated for 
(cannot be in the future). Shares transactions occurring after this date will not be included in the 
dividend calculation. 

Check if the Dividend is Ineligible for the lower tax rate (T5 implications). 

Select the Retained Earnings account for the Debit GL Account (the Dividends Payable account will 
be used for the Credits) and optionally a Location (to allocate the postings). 
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Dividends are declared for all shareholders retrieved. 

 

 

 

Dividends are displayed on the Shareholder Centre and on the Dividends window 
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The Dividend report can be viewed from the Dividends window. 

 

General Ledger > Shares > Dividends > Add 

 
 

Editing Dividends 

Shareholder(s) can be removed from a dividend if an error is found and no payment has been 
made to the shareholder (dividends can also be deleted as long as no payment to any 
shareholder was made). 
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Once removed and the error corrected (name, share quantity, etc.), a new dividend will need to 
be created to include the shareholder(s) that were previously removed. 

 

Dividend Payments 

After a Dividend has been declared, it needs to be paid. 

 

General Ledger > Shares > Dividends 

 

Dividend Payments are a two-step process:  

1. Make the Dividend Payments  

2. Process the Dividend EFTs / Print the Dividend Cheques 

 

1. Make the Dividend Payments 

Dividend Payments are made from the Dividend Payments window. 

 

General Ledger > Shares > Dividend Payments 
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A Location must be selected so agrē knows which Reference Numbers (and which cheque 
numbers) to use. 

If you are entering the Reference number manually, it must be alphanumeric (15 char max) with 
no spaces, leading zeros are allowed. 

 

General Ledger > Shares > Dividend Payments 

Optionally change the Payment Type for a shareholder  
(if multiple payment types are selected, Generate Reference Automatically must be checked). 

Save the Payments. 

 

to process dividend payments by EFT, please refer to the EFT Payments white paper 

Related White Papers 

EFT Payments (Dividend Payments by Electronic Funds Transfer) 

Cheque/EFT Batch Review Process 

https://www.tronia.com/webhelp/assets/docs/AP_EFT_Payments.pdf
https://www.tronia.com/webhelp/assets/docs/AP_EFT_Payments.pdf
https://www.tronia.com/webhelp/assets/docs/AP_Cheque_Batch_Review.pdf
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Dividend Payments are displayed on the Share Transaction window, and on the Shareholder Centre. 

 

Dividend Payments can’t be edited, but they can be Deleted if the cheques haven’t been printed.  

If a mistake was made (perhaps the wrong posting date was selected) an entire batch of 
Dividend Payments can be deleted by clicking the More Options arrow next to the Delete button 
and selecting Delete Batch. 

 

A reason is required to Delete. 

 

When you delete a payment, it’s like it never happened - the payment will not appear in the 
Dividend Payment window, nor will you see it in the Shareholder Centre.  
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2. Process the Dividend EFTs / Print the Dividend Cheques 

Payment by EFT 

Please refer to the EFT Payments white paper as the process for dividend EFT payments is almost 
identical to that of supplier EFT payments. 

 

Payment by Cheque 

Dividend Cheques are printed from the Dividend Payments window. 

 

General Ledger > Shares > Dividend Payments 

 

 

Choose which cheques to print (usually all of them). 

 

https://www.tronia.com/webhelp/assets/docs/AP_EFT_Payments.pdf
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Based on the Location and the Payment Type selected when paying the dividend, agrē will use 
the Next Cheque No as the Starting Cheque Number. 

 

Accounts Payable > Manage > AP Payment Types 

 

 

Print the Dividend Cheques, then close the Dividend Cheque window. 
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After the cheques are successfully printed, you need to let agrē know that you’ve got the paper 
copies you need and you don’t plan on printing them again. 

 

 

 

Saving here will update the cheque payment type with the actual cheque number and flag them 
as having already been printed … so you don’t want to overlook this step!  
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The Dividend Payments window is updated with the Cheque Nos. 

 

 

If you need to Reprint a dividend cheque, click the More Options arrow next to the Print button. 

 

If you need to update the name on the cheque before you reprint it, click Refresh Shareholder 

Name. 
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If a payment includes more than 8 share certificates the details will exceed what can fit on the 
cheque stub. Run the Dividend Cheque Stub Attachment report to print details for all certificates on 
the payment. 

 

General Ledger > Shares > Reports 

If a shareholder requires a replacement, you can Cancel the dividend cheque and prepare a new 
one. 

 

Cancelled dividend payments are displayed only in the Shareholder Centre. 
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CRA Export 

CRA Export will create an XML file for T5 submissions to Canada Revenue Agency. 

(optional) You can Validate the export file against the schema from the CRA website to check for 
errors before you Export. 

Fill in the details on the CRA Export window and click Export.  
You’ll be prompted for a file name. The default name is “t5_YEAR.xml” but can be changed. 

 

General Ledger > Shares > CRA Export 

• Transmitter Number must be 6 digits, and will default to ‘MM555555’ if left blank 

• Account Number (RZ Number) must be 15 characters (9 digits + “RZ” + 4 digits) 

• If no Eligible Gross Up % or DTC (Dividend Tax Credit) is entered the following defaults will be 

used:  

•  Default Gross Up % (eligible): 38.00 

•  Default Gross Up % (ineligible): 15.00 

•  DTC (eligible): 20.73 

•  DTC (ineligible): 10.38 
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• For each T5 Slip: 

•  the actual amount and taxable amount of eligible and ineligible dividends are summed 

for the shareholder for the tax year 

•  the Dividend tax credit for eligible and ineligible dividends are summed for the share-

holder for the tax year 

• If SIN is missing for Shareholder Type 1 or 2, a message will be displayed 

(see Manage Shareholders: Recipient ID Number) 

A message will be sent out once the validation is complete/fails. The message will have Line# and 
the tag name where the validation failed. This will be useful to fix missing or incorrect data 
before the xml is submitted. 

Note: If you have any questions or require further assistance with Shares, please 
contact your CSC at support@tronia.com.  

mailto:support@tronia.com

